Closed Bug 149464 Opened 22 years ago Closed 22 years ago

Installer buggers up file associations for images without asking permission

Categories

(SeaMonkey :: Installer, defect)

x86
All
defect
Not set
major

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 131106

People

(Reporter: rob.stow, Assigned: dveditz)

Details

The Mozilla 1.0 installer - at least for all Windows versions - buggers up the
users file associations for many image types without asking permission first.

Reproducible: always.

Steps:  
1.) Associate images with your favourite image viewer or editor.
    This is typically done simply by installing image editors or
    viewers - all of which are polite enough to ask permission 
    before changing your file associations.
2.) Install Mozilla.
3.) Note that your file associations are now f**ked all to h*ll -
    and Mozilla never asked permission to do this at any stage of 
    the install process.


What on earth was going through the mind of the moron who decided 
that Mozilla should steal file associations for image types away 
from the whatever apps they are currently associated with ?   And 
then they don't even have the brains to at least ask the user if 
he wants to do such an incredibly stupid thing ?

This is absolutely mind boggling.  Who on earth decided that Mozilla
users are all halfwits who would want to associate images with Mozilla 
instead of with ACDSee, PhotoShop, PaintShop Pro, or whatever other 
image viewing or editting software they have ?
>Mozilla never asked
Mozilla asks you if Mozilla should handle file types.
(no list, it reassigns all supported file types if you select "yes")

This is NEVER critical and it's a dupe.


*** This bug has been marked as a duplicate of 131106 ***
Severity: critical → major
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
v dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.