wpt reftest harness shows failures due to differences in the corners on Mac

RESOLVED FIXED in Firefox 64

Status

defect
RESOLVED FIXED
8 months ago
7 months ago

People

(Reporter: jgraham, Assigned: jgraham)

Tracking

Version 3
mozilla64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

8 months ago
When reusing a cached canvas, the wpt reftest harness sometimes shows differences in the lower corners of images on mac (typically 6 or 14 different pixels, and a difference of 1 in the channel value). It's not really clear why this happens, but it seems to be related to transparency and the rounded corners on OSX. Disabling window chrome seems to fix the problem.
Assignee

Comment 1

8 months ago
This fixes a problem caused by rounded corners on macOS.

Depends on D7198
Comment on attachment 9012946 [details]
Bug 1494719 - Set hidechrome on reftest window,

Andreas Tolfsen ❲:ato❳ has approved the revision.
Attachment #9012946 - Flags: review+
Attachment #9012946 - Attachment description: Bug 1494719 - Set hidechrome on reftest window → Bug 1494719 - Set hidechrome on reftest window,

Comment 4

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ec819897ecf5
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Assignee: nobody → james
You need to log in before you can comment on or make changes to this bug.