The pref checks in bug 1491061 are still not right

RESOLVED FIXED in Firefox 63

Status

()

enhancement
P1
normal
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

unspecified
Firefox 64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 fixed, firefox64 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

8 months ago
The beta landing yesterday bounced again because of two more test failures:

https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&revision=a5e0c4e767747994f72b53e8b6073395663f72f1

The enterprise policy test failure shows that we should not be checking browser.contentblocking.ui.enabled after all, since that breaks blocking all third-part cookies on beta when that pref is disabled.  :-(
Assignee

Comment 1

8 months ago
In my patch here I'm fixing the tests in a very hacky way to ease the backport.  We should fix up the tests to remove blockingByContentBlockingUI for example later in a patch that won't get uplifted.
Status: NEW → ASSIGNED
Priority: -- → P1
Comment on attachment 9012677 [details]
Bug 1494737 - Don't check browser.contentblocking.ui.enabled in AntiTrackingCommon::ShouldHonorContentBlockingCookieRestrictions()

Andrea Marchesini [:baku] has approved the revision.
Attachment #9012677 - Flags: review+
Assignee

Comment 4

8 months ago
Comment on attachment 9012677 [details]
Bug 1494737 - Don't check browser.contentblocking.ui.enabled in AntiTrackingCommon::ShouldHonorContentBlockingCookieRestrictions()

Approval Request Comment
This is the last piece needed for bug 1491061, please see the approval request in that bug for risk analysis etc.
Attachment #9012677 - Flags: approval-mozilla-beta?

Comment 5

8 months ago
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/197cb402f89a
Don't check browser.contentblocking.ui.enabled in AntiTrackingCommon::ShouldHonorContentBlockingCookieRestrictions(); r=baku
Assignee

Updated

8 months ago
Duplicate of this bug: 1494642
Comment on attachment 9012677 [details]
Bug 1494737 - Don't check browser.contentblocking.ui.enabled in AntiTrackingCommon::ShouldHonorContentBlockingCookieRestrictions()

test fixes for bug 1491061, uplift approved for 63 beta 11
Attachment #9012677 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 9

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/197cb402f89a
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.