Closed Bug 1495030 Opened Last year Closed Last year

Add GV API for blocking third-party tracker cookies

Categories

(GeckoView :: General, defect, P1)

Unspecified
Android
defect

Tracking

(geckoview62 wontfix, firefox62 wontfix, firefox63 fixed, firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
geckoview62 --- wontfix
firefox62 --- wontfix
firefox63 --- fixed
firefox64 --- fixed

People

(Reporter: cpeterson, Assigned: esawin)

References

Details

(Whiteboard: [geckoview:klar:p2])

Attachments

(1 file)

Focus would like [1] to offer separate options for blocking third-party *tracker* cookies separate from blocking *all* third-party cookies. Firefox desktop is adding a new tracker cookie blocklist. The GV API will need a way to specify this new tracker cookie blocklist.

Is the new tracker cookie blocklist in Firefox 63 or 64?

[1] Provide similar auto privacy features than Desktop: https://github.com/mozilla-mobile/focus-android/issues/3319
Focus issue: Additional Cookie Protection Option (3rd party tracker cookies)

https://github.com/mozilla-mobile/focus-android/issues/3515
P1 because the Focus team would like this feature for Focus 8.0. TBD whether GV 63 has the tracker cookie blocklist that they need. GV 64 won't ship until December 12, after Focus 8.0 will ship.
Eugen will sort this out.
Assignee: nobody → esawin
Priority: -- → P1
Whiteboard: [geckoview:klar:p2]
Looks like it's simply an additional cookie behaviour (pref) value we need to expose.
Attachment #9014522 - Flags: review?(snorp)
Attachment #9014522 - Flags: review?(francois)
Depends on: 1480780
Comment on attachment 9014522 [details] [diff] [review]
0001-Bug-1495030-1.0-Add-third-party-tracker-cookies-bloc.patch

Review of attachment 9014522 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine to me, but let's just double-check with baku since he's the one who added this new cookie option.
Attachment #9014522 - Flags: review?(francois) → review?(amarchesini)
Attachment #9014522 - Flags: review?(amarchesini) → review+
Pushed by esawin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8dcf2e242b3a
[1.0] Add third-party tracker cookies blocking setting. r=snorp,baku
https://hg.mozilla.org/mozilla-central/rev/8dcf2e242b3a
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Eugen, can we uplift this new API to GV 63 Beta? The Focus team would like to expose this setting to users in Focus 8.0 (which will ship GV 63).
Flags: needinfo?(esawin)
Comment on attachment 9014522 [details] [diff] [review]
0001-Bug-1495030-1.0-Add-third-party-tracker-cookies-bloc.patch

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Third-party tracker cookie blocking

User impact if declined: Focus will not be able to expose tracker cookie blocking setting for desktop-parity.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): This only exposes an additional pref value through an existing GeckoView API.

String changes made/needed: None
Flags: needinfo?(esawin)
Attachment #9014522 - Flags: approval-mozilla-beta?
Comment on attachment 9014522 [details] [diff] [review]
0001-Bug-1495030-1.0-Add-third-party-tracker-cookies-bloc.patch

Minimal patch, P1 for Geckoview, uplift approved for 63 beta 13, thanks.
Attachment #9014522 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Product: Firefox for Android → GeckoView
Target Milestone: Firefox 64 → mozilla64
You need to log in before you can comment on or make changes to this bug.