Clicking any input in macOS native color picker hangs Firefox

RESOLVED DUPLICATE of bug 1489785

Status

()

defect
RESOLVED DUPLICATE of bug 1489785
7 months ago
7 months ago

People

(Reporter: chris, Unassigned)

Tracking

62 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180920131237

Steps to reproduce:

1. Open any page with an input with type="color". This one will work: https://codepen.io/anon/pen/dgyxYQ
2. Click the input to open the macOS color picker widget.
3. Click any text input box - for example, under the Color Sliders tab click the Hex Color # field.


Actual results:

Firefox hangs.

Crash report is here: https://crash-stats.mozilla.com/report/index/c6673d31-b9e5-45d1-8e1d-100330180928

I've reviewed #1389908 but this is a different bug.

I've confirmed this in Safe Mode, with a new profile, and on Nightly 64.0a1.


Expected results:

The field should be editable.
could be a dupe of bug 1489785
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Component: Widget: Gtk → Widget: Cocoa
(Reporter)

Comment 2

7 months ago
Tested in Nightly 64.0a1 (2018-10-02) and the issue is now resolved. Closing now as WorksForMe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
Thanks for the report Chris !
I'm pretty sure that this is a dupe of bug 1489785 when the color picker now works after bug 1489785 got fixed.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1489785
You need to log in before you can comment on or make changes to this bug.