Closed Bug 1495475 Opened 1 year ago Closed 1 year ago

Warn on using desiredCapabilities/requiredCapabilities

Categories

(Testing :: geckodriver, enhancement, P1)

enhancement

Tracking

(firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: ato, Assigned: ato)

References

Details

Attachments

(1 file)

Since we want to remove support for Selenium-styled new session
requests before releasing geckodriver 1.0, we could could ease the
transition for users by issuing a warning when users attempt to use
desiredCapabilities or requiredCapabilities.

If we wanted to be really nice we could write some documentation
on how to upgrade from desiredCapabilities/requiredCapabilities to
the WebDriver conforming new session negotiation pattern.
Blocks: 1495062
Priority: -- → P3
This emits a warning when the webdriver library reverts to using the
legacy Selenium-styled capabilities negotiation for new sessions.
It provides a helpful link which will explain to users how to update.
Assignee: nobody → ato
Status: NEW → ASSIGNED
Priority: P3 → P1
Comment on attachment 9013351 [details]
bug 1495475: webdriver: warn on using desiredCapabilities/requiredCapabilities

Henrik Skupin (:whimboo) has approved the revision.
Attachment #9013351 - Flags: review+
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/549b5d7a277b
webdriver: warn on using desiredCapabilities/requiredCapabilities r=whimboo
https://hg.mozilla.org/mozilla-central/rev/549b5d7a277b
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Blocks: 1491288
No longer blocks: 1495062
You need to log in before you can comment on or make changes to this bug.