Closed Bug 1495589 Opened Last year Closed Last year

Crash in js::GCMarker::traverse<T>

Categories

(Core :: JavaScript: GC, defect, critical)

Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1475821

People

(Reporter: gsvelto, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-e774f1e4-1f0f-4f08-99c9-0a4190180930.
=============================================================

Top 10 frames of crashing thread:

0 XUL void js::GCMarker::traverse<js::ObjectGroup*> js/public/HeapAPI.h:494
1 XUL js::GCMarker::drainMarkStack js/src/gc/Marking.cpp:905
2 XUL js::gc::GCRuntime::incrementalCollectSlice js/src/gc/GC.cpp:6270
3 XUL js::gc::GCRuntime::gcCycle js/src/gc/GC.cpp:7940
4 XUL js::gc::GCRuntime::collect js/src/gc/GC.cpp:8121
5 XUL mozilla::dom:: js/src/gc/GC.cpp:8204
6 XUL nsTimerImpl::Fire xpcom/threads/nsTimerImpl.cpp:701
7 XUL nsTimerEvent::Run xpcom/threads/TimerThread.cpp:297
8 XUL mozilla::dom:: dom/workers/WorkerEventTarget.cpp:46
9 XUL mozilla::dom::WorkerRunnable::Run dom/workers/WorkerRunnable.cpp:380

=============================================================
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1475821
You need to log in before you can comment on or make changes to this bug.