Closed Bug 1495672 Opened Last year Closed 6 months ago

error: failed to run custom build command for `baldrdash v0.1.0` on MacOS 10.14

Categories

(Firefox Build System :: General, defect, blocker)

Desktop
macOS
defect
Not set
blocker

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: daoshengmu, Assigned: standard8)

References

Details

(Keywords: dogfood)

Attachments

(1 file)

OS: MacOS 10.14
Rust: rustc 1.31.0-nightly (de3d640f5 2018-10-01), rustc 1.29.1-stable


7:52.69 error: failed to run custom build command for `baldrdash v0.1.0 (/Projects/mozilla/gecko-dev/js/src/wasm/cranelift)`
 7:52.69 process didn't exit successfully: `/Projects/mozilla/gecko_build/js/src/rust/release/build/baldrdash-d6e1929d79a64de3/build-script-build` (exit code: 101)
 7:52.69 --- stdout
 7:52.69 cargo:rerun-if-changed=baldrapi.h
 7:52.69 cargo:rerun-if-changed=/Projects/mozilla/gecko_build/js/src/rust/extra-bindgen-flags
 7:52.69 --- stderr
 7:52.70 /usr/local/Cellar/llvm/4.0.1/bin/../lib/clang/4.0.1/include/inttypes.h:30:15: fatal error: 'inttypes.h' file not found
 7:52.70 /usr/local/Cellar/llvm/4.0.1/bin/../lib/clang/4.0.1/include/inttypes.h:30:15: fatal error: 'inttypes.h' file not found, err: true
 7:52.70 thread 'main' panicked at 'Unable to generate baldrapi.h bindings: ()', libcore/result.rs:1009:5
 7:52.70 stack backtrace:
 7:52.70    0:        0x1009cf75f - std::sys::unix::backtrace::tracing::imp::unwind_backtrace::heb6afa683932dedf
 7:52.70    1:        0x1009c0abd - std::sys_common::backtrace::print::h766ca70084cc68f0
 7:52.70    2:        0x1009d40a3 - std::panicking::default_hook::{{closure}}::hf3402f90591bf7bb
 7:52.70    3:        0x1009d3e2c - std::panicking::default_hook::hb3b7f3a59e2ecd5a
 7:52.70    4:        0x1009d47d7 - std::panicking::rust_panic_with_hook::h359374823d95520e
 7:52.70    5:        0x1009d433c - std::panicking::continue_panic_fmt::hf199d5eb60536380
 7:52.70    6:        0x1009d4228 - rust_begin_unwind
 7:52.70    7:        0x100a16681 - core::panicking::panic_fmt::he16a30f6c103fffa
 7:52.70    8:        0x100837cbe - core::result::unwrap_failed::h2544233a40bc3bc3
 7:52.70    9:        0x100837213 - build_script_build::main::h1955e5fa41454adb
 7:52.70   10:        0x10083bd55 - std::rt::lang_start::{{closure}}::h26b2f0290056028f
 7:52.70   11:        0x1009d41a7 - std::panicking::try::do_call::h2bd103f24173fc3c
 7:52.70   12:        0x1009e0b8e - __rust_maybe_catch_panic
 7:52.70   13:        0x1009c79cc - std::rt::lang_start_internal::h6fb67bdf1de01d4a
 7:52.70   14:        0x10083bd47 - std::rt::lang_start::he283708e3417cd61



9:49.01 /usr/local/Cellar/llvm/4.0.1/bin/../lib/clang/4.0.1/include/inttypes.h:30:15: fatal error: 'inttypes.h' file not found
 9:49.01 /usr/local/Cellar/llvm/4.0.1/bin/../lib/clang/4.0.1/include/inttypes.h:30:15: fatal error: 'inttypes.h' file not found, err: true
 9:49.01 thread 'main' panicked at 'Unable to generate baldrapi.h bindings: ()', libcore/result.rs:1009:5
 9:49.01 stack backtrace:
 9:49.01    0:        0x101e26e0f - std::sys::unix::backtrace::tracing::imp::unwind_backtrace::heb6afa683932dedf
 9:49.01    1:        0x101e06c7d - std::sys_common::backtrace::print::h766ca70084cc68f0
 9:49.01    2:        0x101e2fae3 - std::panicking::default_hook::{{closure}}::hf3402f90591bf7bb
 9:49.02    3:        0x101e2f86c - std::panicking::default_hook::hb3b7f3a59e2ecd5a
 9:49.02    4:        0x101e30217 - std::panicking::rust_panic_with_hook::h359374823d95520e
 9:49.02    5:        0x101e2fd7c - std::panicking::continue_panic_fmt::hf199d5eb60536380
 9:49.02    6:        0x101e2fc68 - rust_begin_unwind
 9:49.02    7:        0x101e940f1 - core::panicking::panic_fmt::he16a30f6c103fffa
 9:49.02    8:        0x100768fc7 - core::result::unwrap_failed::h9a0fd4bf02fdca71
 9:49.02                                at libcore/macros.rs:26
 9:49.02    9:        0x100765ea4 - <core::result::Result<T, E>>::expect::h7487f000e002baca
 9:49.02                                at libcore/result.rs:835
 9:49.02   10:        0x100767e33 - build_script_build::main::h3d0b698d04d2ae58
 9:49.02                                at js/src/wasm/cranelift/build.rs:128
 9:49.02   11:        0x10076aa65 - std::rt::lang_start::{{closure}}::h94174cfa39bdbc89
 9:49.02                                at libstd/rt.rs:74
 9:49.02   12:        0x101e2fbe7 - std::panicking::try::do_call::h2bd103f24173fc3c
 9:49.02   13:        0x101e3d5fe - __rust_maybe_catch_panic
 9:49.02   14:        0x101e1392c - std::rt::lang_start_internal::h6fb67bdf1de01d4a
 9:49.02   15:        0x10076aa57 - std::rt::lang_start::heaf0d829dd9eee9e
 9:49.02                                at libstd/rt.rs:74
 9:49.02 warning: build failed, waiting for other jobs to finish...
10:03.62 error: build failed
10:03.63 make[4]: *** [force-cargo-library-build] Error 101
10:03.63 make[3]: *** [toolkit/library/rust/target] Error 2
After pulling the latest source code from m-c, it happens to me. It seems like baldrdash build failed in rust compiler. :bbouvier, do you have any idea about this?
Flags: needinfo?(bbouvier)
I suspect this is a duplicate of bug 1495610, where I've posted a patch. Can you try it, please?
Flags: needinfo?(bbouvier) → needinfo?(dmu)
It works after applying your patch and run the package at /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.
Flags: needinfo?(dmu)
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Product: Toolkit → Toolkit Graveyard
For the next person that runs across this. Clarification on comment 3:

open /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg

Is there a way that we can detect this problem and print a helpful message early in the build? I just updated to 10.14.4 and hit this again and it took me far more time than I'd like to find this again.

Flags: needinfo?(spohl.mozilla.bugs)

Forwarding to someone who's probably in a better position to answer this question.

Flags: needinfo?(spohl.mozilla.bugs) → needinfo?(bbouvier)

Is it the issue described in bug 1487552? If so, people there seemed to have an idea of what the next steps should be.

Flags: needinfo?(bbouvier)

Ah yes, that looks like it.

Re-opening this, since it isn't fixed, and I've just hit it again and we should have this for ease of searching in bugzilla. This will probably get fixed by bug 1487552, but I think we need the visibility here.

Blocks: 1487552
Severity: normal → blocker
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
No longer blocks: 1487552
Depends on: 1487552
Component: Build Config → General
Keywords: dogfood
Product: Toolkit Graveyard → Firefox Build System

I've just hit this again. So I took a look and I think I've got a solution that works. Probably not perfect, but better than nothing.

Assignee: nobody → standard8
Status: REOPENED → ASSIGNED
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/04e6c1201e2a
Block configure if the Mac OS X headers are not installed on 10.14. r=froydnj
Status: ASSIGNED → RESOLVED
Closed: Last year6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Regressions: 1547847

This was only fixed for me by bug 1526857.

See Also: → 1526857
You need to log in before you can comment on or make changes to this bug.