Closed Bug 1495738 Opened Last year Closed Last year

Image cache entry should not be reused when Cache-Control header is received

Categories

(Core :: ImageLib, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: baku, Assigned: baku)

References

Details

Attachments

(1 file)

I managed to reproduce a race condition where a cached image is used also when the Cache-Control header has been received This happens because we consider valid cache entries, images with no-cache header if used in the same document. This comparison is based on a loadID which is the document's pointer. But that pointer can be reused for another document and we end up exposing a cached image when we should not.
Attached patch img.patchSplinter Review
Attachment #9013606 - Flags: review?(aosmond)
Attachment #9013606 - Flags: review?(aosmond) → review+
Priority: -- → P3
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/135eaacf1dfc
Image cache entry should compare the window ID together with the loadID because the loadID can be a reused pointer, r=aosmond
https://hg.mozilla.org/mozilla-central/rev/135eaacf1dfc
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Regressions: 1563493
No longer regressions: 1563493
Regressions: 1580820
Regressions: 1563493
You need to log in before you can comment on or make changes to this bug.