Closed Bug 1495770 Opened Last year Closed Last year

AWS Lambda dashboard does not function properly on latest Firefox Nightly

Categories

(Core :: Layout: Form Controls, defect)

64 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1496754
Tracking Status
firefox64 --- fixed

People

(Reporter: austin, Unassigned)

Details

(Keywords: nightly-community, regression, regressionwindow-wanted)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:64.0) Gecko/20100101 Firefox/64.0
Build ID: 20181002100236

Steps to reproduce:

Sign into AWS.
Go to Lambda Dashboard.
Try to create a new Lambda.
(Nothing happens, no errors, no new Lambda).
OR
Sign into AWS.
Go to Lambda Dashboard.
Go to existing Lambda function.
Try to upload a ZIP for the Lambda function.
(Nothing happens: no zip is uploaded).


Actual results:

Nothing. AWS gives no feedback, Lambdas are not created, code is not uploaded.


Expected results:

A new Lambda should be created OR AWS should spit out an error message. Neither happens. Same with uploading code via a ZIP file. I have confirmed that on the exact same account on the same computer with the same IP that the same functionality works perfectly normal in the Developer Edition of Firefox.

I also believe this is a recent Nightly issue as I have been using Nightly with Lambda for at least two weeks and did not notice this issue until the end of last week.
I also cannot test lambdas within the dashboard (i.e. they cannot be invoked from the dashboard in Firefox Nightly even when they can be invoked remotely and from other browsers like Firefox dev edition).

When I try and invoke a lambda from their dashboard on Firefox Nightly, I get a 403 with the following payload

"message: The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details."
I think this would be a Core: Layout Form Controls issue. Please correct if this isn't the right component. Thanks!
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core
(In reply to Grover Wimberly IV [:Grover-QA] from comment #2)
> I think this would be a Core: Layout Form Controls issue. Please correct if
> this isn't the right component. Thanks!

I don't think there's any evidence for that.

(In reply to austin from comment #1)
> I also cannot test lambdas within the dashboard (i.e. they cannot be invoked
> from the dashboard in Firefox Nightly even when they can be invoked remotely
> and from other browsers like Firefox dev edition).
> 
> When I try and invoke a lambda from their dashboard on Firefox Nightly, I
> get a 403 with the following payload
> 
> "message: The request signature we calculated does not match the signature
> you provided. Check your AWS Secret Access Key and signing method. Consult
> the service documentation for details."

Is there any chance you could run mozregression to pin point a regression range? I don't have an AWS account to investigate handy.

  https://mozilla.github.io/mozregression/quickstart.html

Thanks!
Flags: needinfo?(austin)
(In reply to Emilio Cobos Álvarez (:emilio) from comment #3)
> (In reply to Grover Wimberly IV [:Grover-QA] from comment #2)
> > I think this would be a Core: Layout Form Controls issue. Please correct if
> > this isn't the right component. Thanks!
> 
> I don't think there's any evidence for that.
> 
> (In reply to austin from comment #1)
> > I also cannot test lambdas within the dashboard (i.e. they cannot be invoked
> > from the dashboard in Firefox Nightly even when they can be invoked remotely
> > and from other browsers like Firefox dev edition).
> > 
> > When I try and invoke a lambda from their dashboard on Firefox Nightly, I
> > get a 403 with the following payload
> > 
> > "message: The request signature we calculated does not match the signature
> > you provided. Check your AWS Secret Access Key and signing method. Consult
> > the service documentation for details."
> 
> Is there any chance you could run mozregression to pin point a regression
> range? I don't have an AWS account to investigate handy.
> 
>   https://mozilla.github.io/mozregression/quickstart.html
> 
> Thanks!

I am having trouble running any regressions after "2018-03-12" on my machine at the moment (some type of permissions issue that I don't presently have time to resolve); however, I can confirm that I am able to create Lambdas in the AWS dashboard on "2018-03-12".

If I'm able to run these regressions again later I will update. My only wild theory at this point is that it's an AWS x Mozilla issue where they're using familiar User Agents to help calculate some kind of security key, and the newest alpha builds just aren't under that umbrella yet. Unfortunately, AWS provides no way to create a ticket about this kind of thing.
Flags: needinfo?(austin)
Thanks for giving it a shot, that's really useful :)

If you could narrow it down it'd be really amazing, but no problems if not, it's already very valuable.

If you had time, though, does creating one work on the latest nightly with an user agent like the one on release, like:

  "Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0"

?

I assume it actually works on Firefox 62... You can change the user agent with the general.useragent.override pref, as described in:

  https://superuser.com/questions/98798/how-do-i-change-firefoxs-user-agent-via-aboutconfig

Thanks a lot again!
Is this a dupe of bug 1496754?
(In reply to austin from comment #0)
> User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:64.0)
> Gecko/20100101 Firefox/64.0
> Build ID: 20181002100236
> 
> Steps to reproduce:
> 
> Sign into AWS.
> Go to Lambda Dashboard.
> Try to create a new Lambda.
> (Nothing happens, no errors, no new Lambda).
> OR
> Sign into AWS.
> Go to Lambda Dashboard.
> Go to existing Lambda function.
> Try to upload a ZIP for the Lambda function.
> (Nothing happens: no zip is uploaded).

(In reply to Julien Cristau [:jcristau] from comment #6)
> Is this a dupe of bug 1496754?

I think so.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1496754
(In reply to Mike Taylor [:miketaylr] (62 Regression Engineering Owner) from comment #7)
> (In reply to austin from comment #0)
> > User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:64.0)
> > Gecko/20100101 Firefox/64.0
> > Build ID: 20181002100236
> > 
> > Steps to reproduce:
> > 
> > Sign into AWS.
> > Go to Lambda Dashboard.
> > Try to create a new Lambda.
> > (Nothing happens, no errors, no new Lambda).
> > OR
> > Sign into AWS.
> > Go to Lambda Dashboard.
> > Go to existing Lambda function.
> > Try to upload a ZIP for the Lambda function.
> > (Nothing happens: no zip is uploaded).
> 
> (In reply to Julien Cristau [:jcristau] from comment #6)
> > Is this a dupe of bug 1496754?
> 
> I think so.

Sorry if this is pedantic, but isn't _that_ issue a duplicate of _this_ one?
> Sorry if this is pedantic, but isn't _that_ issue a duplicate of _this_ one?

Maybe, but the other issue has the correct diagnosis happening in it. Seems less noisy to dupe this over to that.
You need to log in before you can comment on or make changes to this bug.