Completion Date for each Bug

RESOLVED DUPLICATE of bug 103636

Status

()

Bugzilla
Bugzilla-General
--
enhancement
RESOLVED DUPLICATE of bug 103636
16 years ago
5 years ago

People

(Reporter: Salmaan Shikari, Assigned: justdave)

Tracking

Details

Attachments

(22 attachments)

2.89 KB, text/plain
Details
27.64 KB, text/plain
Details
9.58 KB, text/plain
Details
5.00 KB, text/plain
Details
44.20 KB, text/plain
Details
19.45 KB, text/plain
Details
4.78 KB, text/plain
Details
56.13 KB, text/plain
Details
24.48 KB, text/plain
Details
50.03 KB, text/plain
Details
56.12 KB, text/plain
Details
5.07 KB, text/plain
Details
1.64 KB, text/plain
Details
920 bytes, text/plain
Details
1.21 KB, text/plain
Details
3.92 KB, text/plain
Details
906 bytes, text/plain
Details
2.05 KB, text/plain
Details
2.05 KB, text/plain
Details
4.36 KB, text/plain
Details
869 bytes, text/plain
Details
814 bytes, text/plain
Details
(Reporter)

Description

16 years ago
This is my first posting.  (I have made the changes on my 2.14.1 version of 
Bugzilla and they are working)

This enhancement requires changes in the following files:
show_bug.cgi
query.cgi
post_bug.cgi
long_list.cgi
globals.pl
enter_bug.cgi
colchange.cgi
buglist.cgi
bug_form.pl
CGI.pl
process_bug.cgi
-------------------------------
I suggest that Bugzilla include the option to enter a Completion Date field for 
every bug.

1. The Completion Date should be set by the reporter.
2. The Completion Date should only be changed by the bug's component owner.
3. The addition of this date will require a new field "completion_date" added
to the "bugs" table.
4. Show the Completion date in the Query Results page, Long Format and normal 
view when editing a bug.
5. Allow user to sort query results by completion date.
(Reporter)

Comment 1

16 years ago
Created attachment 86618 [details]
show_bug.cgi with modifications for completion date

The changes made to this file implement the completion date enhancement.
(Reporter)

Comment 2

16 years ago
Created attachment 86619 [details]
query.cgi with modifications for completion date

query.cgi with modifications for completion date
(Reporter)

Comment 3

16 years ago
Created attachment 86621 [details]
post_bug.cgi with modifications for completion date

post_bug.cgi with modifications for completion date
(Reporter)

Comment 4

16 years ago
Created attachment 86622 [details]
long_list.cgi with modifications for completion date

long_list.cgi with modifications for completion date
(Reporter)

Comment 5

16 years ago
Created attachment 86623 [details]
globals.pl with modifications for completion date

globals.pl with modifications for completion date
(Reporter)

Comment 6

16 years ago
Created attachment 86624 [details]
globals.pl with modifications for completion date

globals.pl with modifications for completion date
(Reporter)

Comment 7

16 years ago
Created attachment 86626 [details]
col_change.cgi with modifications for completion date

col_change.cgi with modifications for completion date
(Reporter)

Comment 8

16 years ago
Created attachment 86627 [details]
buglist.cgi with modifications for completion date

buglist.cgi with modifications for completion date
(Reporter)

Comment 9

16 years ago
Created attachment 86628 [details]
bug_form.pl with modifications for completion date

bug_form.pl with modifications for completion date
(Reporter)

Comment 10

16 years ago
Created attachment 86629 [details]
CGI.pl with modifications for completion date

CGI.pl with modifications for completion date
(Reporter)

Comment 11

16 years ago
Created attachment 86630 [details]
process_bug.cgi with modifications for completion date

process_bug.cgi with modifications for completion date
Salmaan: Can you make diffs with diff -u of the original files against your
changes and upload that instead of the entire files?

reviewing entire files is very difficult for what is likely small changes to
many of these files.
(Reporter)

Comment 13

16 years ago
Created attachment 86648 [details]
diff -u bug_form.pl (original) bug_form.pl (with changes)

diff -u bug_form.pl (original) bug_form.pl (with changes)
(Reporter)

Comment 14

16 years ago
Created attachment 86649 [details]
diff -u buglist.cgi (original) buglist.cgi (with changes)

diff -u buglist.cgi (original) buglist.cgi (with changes)
(Reporter)

Comment 15

16 years ago
Created attachment 86650 [details]
diff -u CGI.pl (original) CGI.pl (with changes)

diff -u CGI.pl (original) CGI.pl (with changes)
(Reporter)

Comment 16

16 years ago
Created attachment 86651 [details]
diff -u colchange.cgi (original) colchange.cgi (with changes)

diff -u colchange.cgi (original) colchange.cgi (with changes)
(Reporter)

Comment 17

16 years ago
Created attachment 86653 [details]
diff -u enter_bug.cgi (original) enter_bug.cgi (with changes)

diff -u enter_bug.cgi (original) enter_bug.cgi (with changes)
(Reporter)

Comment 18

16 years ago
Created attachment 86654 [details]
diff -u globals.pl (original) globals.pl (with changes)

diff -u globals.pl (original) globals.pl (with changes)
(Reporter)

Comment 19

16 years ago
Created attachment 86656 [details]
diff -u long_list.cgi (original) long_list.cgi (with changes)

diff -u long_list.cgi (original) long_list.cgi (with changes)
(Reporter)

Comment 20

16 years ago
Created attachment 86658 [details]
diff -u post_bug.cgi (original) post_bug.cgi (with changes)

diff -u post_bug.cgi (original) post_bug.cgi (with changes)
(Reporter)

Comment 21

16 years ago
Created attachment 86659 [details]
diff -u process_bug.cgi (original) process_bug.cgi (with changes)

diff -u process_bug.cgi (original) process_bug.cgi (with changes)
(Reporter)

Comment 22

16 years ago
Created attachment 86660 [details]
diff -u query.cgi (original) query.cgi (with changes)

diff -u query.cgi (original) query.cgi (with changes)
(Reporter)

Comment 23

16 years ago
Created attachment 86661 [details]
diff -u show_bug.cgi (original) show_bug.cgi (with changes)

diff -u show_bug.cgi (original) show_bug.cgi (with changes)

Comment 24

16 years ago
Salmaan,

this cannot be reviewed like this, sorry. Here are some comments which could
help you further:

It's quite straining to review and apply a zillion-file patch set - just diff -u
all the modifications into a single patch file. You don't have to attach that
many files and we can only download one.

Your version management system has added some comments to all the files. We
don't want these comments into the bugzilla trunk code. Additionally, the
comments contain a copyright statement. Please understand that unless the patch
is released under MPL, we cannot use it. There is already a copyright heading in
the file; another is not needed.

The patch is against Bugzilla version 2.14.1, but unfortunately most of the
output code has been rewritten and templatized since then - we need patches for
the current codebase (2.17-trunk). 

If you need a schema change (that new field in the bugs table), you also need to
alter checksetup.pl.

Also note that we have a custom fields implementation coming up; check out bug 
91037. Slightly similar is also bug 24789, and bug 62370 is doing the same thing
from a bit different angle. Would some of these be of any assistance?

Please check out the Bugzilla hacking manuals from www.bugzilla.org, section
"How can you help". They will give you some ideas about how to push this forward.
Component: Administration → Bugzilla-General
OS: Windows 2000 → All
Hardware: PC → All

Comment 25

15 years ago
*** Bug 189762 has been marked as a duplicate of this bug. ***

Comment 26

15 years ago
Is this not a dup of bug 103636 ?

Comment 27

14 years ago
Technically, maybe, but in practical terms, yes.

*** This bug has been marked as a duplicate of 103636 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.