Closed Bug 1496108 Opened Last year Closed 11 months ago

USB Runtimes not appearing the first time about:debugging is opened

Categories

(DevTools :: about:debugging, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1493104

People

(Reporter: ladybenko, Unassigned)

References

Details

USB runtimes do not appear on the sidebar the first time `about:debugging` is opened. They do show up after reloading the page.

Steps:

- Make a new build
- Connect an Android phone via USB and open Firefox on it
- Open `about:debugging`
=> the runtime doesn't appear
=> a `ADB extension not installed` error yielded by `usb-runtimes.js` appears in the console
- Reload the page (Cmd + R)
=> the runtime appears in the sidebar
=> no ADB extension error in the console
Priority: -- → P2
Looked at this quickly, usb-runtimes synchronously calls `getAvailableAddons().adb`  on webide's addons module:
https://searchfox.org/mozilla-central/rev/924e3d96d81a40d2f0eec1db5f74fc6594337128/devtools/client/webide/modules/addons.js#43-50

If this is the first time this method is called, the ADB addon instance will be initialized with the status "unknown". We should wait for the status to be updated. Maybe the ADBaddon constructor could expose a promise to know when the state has been updated.

I will do that with the cleaned up module from Bug 1494615
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: P2 → P1
Unassigning myself while I work on blocking bug 1493104 (I suspect I will end up closing this as duplicate after that).
Assignee: jdescottes → nobody
Status: ASSIGNED → NEW
Priority: P1 → P2
QA Contact: jdescottes
QA Contact: jdescottes
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1493104
No longer blocks: remote-debugging-ng-m1
You need to log in before you can comment on or make changes to this bug.