Closed Bug 1496114 Opened Last year Closed Last year

Permafailing wpt failures on /feature-policy/payment-allowed-by-feature-policy-attribute-redirect-on-load.https.sub.html when Gecko 64 merges to Beta on 2018-10-15

Categories

(Core :: DOM: Core & HTML, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1495301
Tracking Status
geckoview62 --- unaffected
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 + fixed

People

(Reporter: tiberius_oros, Assigned: baku)

Details

(Whiteboard: [stockwell unknown])

Attachments

(1 file)

This appears to be from bug 1495359. 

Andrea can you please take a look?
Depends on: 1495359
Flags: needinfo?(amarchesini)
No longer depends on: 1495359
Summary: Permafailing wpt failures on /feature-policy/payment-allowed-by-feature-policy-attribute-redirect-on-load.https.sub.html → Permafailing wpt failures on /feature-policy/payment-allowed-by-feature-policy-attribute-redirect-on-load.https.sub.html when Gecko 64 merges to Beta on 2018-10-15
The problem is that payment API is completely disabled in nightly. This means we cannot enable it by pref in order to run those WPTs:

https://searchfox.org/mozilla-central/rev/3c85ea2f8700ab17e38b82d77cd44644b4dae703/dom/payments/PaymentRequest.cpp#63-68

I can submit a patch to change this code, or I can disable the tests for beta.
Flags: needinfo?(amarchesini)
Attached patch pref.patchSplinter Review
Assignee: nobody → amarchesini
Attachment #9014094 - Flags: review?(mcaceres)
Comment on attachment 9014094 [details] [diff] [review]
pref.patch

Review of attachment 9014094 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #9014094 - Flags: review?(mcaceres) → review+
Priority: -- → P2
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/474f3df15a58
PaymentRequest CTOR is controlled by pref, r=marcosc
We should uplift this patch when in central.
Flags: needinfo?(apavel)
https://hg.mozilla.org/mozilla-central/rev/474f3df15a58
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Flags: needinfo?(apavel)
(In reply to Andrea Marchesini [:baku] from comment #7)
> We should uplift this patch when in central.
The beta simulations are done with the good in the central tree. The issue should be gone in today's beta simulations. Do you want it uplifted for other reasons? If yes, please request beta approval.
QA Contact: overholt
QA Contact: overholt
Looks like this issue was not fixed, is still present on beta sims.

https://treeherder.mozilla.org/logviewer.html#?job_id=204498399&repo=try&lineNumber=13379
Status: RESOLVED → REOPENED
Flags: needinfo?(amarchesini)
Resolution: FIXED → ---
Target Milestone: mozilla64 → ---
Baku, since UI code is not packaged into the Beta, when running tests, the lack of UI introduces errors/crashes. So I would like to check in the patch on bug 1495301 to avoid crashing tests.
Sounds good to me.
Flags: needinfo?(amarchesini)
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → DUPLICATE
Duplicate of bug: 1495301
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.