Closed Bug 1496243 Opened 11 months ago Closed 10 months ago

When third party tracking cookies are blocked, control center says all third party cookies are blocked

Categories

(Firefox :: Site Identity and Permission Panels, enhancement, P1)

63 Branch
enhancement

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox64 --- fixed

People

(Reporter: tanvi, Assigned: johannh, NeedInfo)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [privacy-panel])

Attachments

(1 file)

If a user has selected cookie behavior 4 (block third party tracking cookies), then display the following in the Control Center:
"Third-Party Tracking Cookies"

If a user has selected cookie behavior 1 (block all third party cookies), then display the following in the Control Center:
"Third-Party Cookies"

This is because, without this change, the UI for a user with behavior 4 would say "Third-Party Cookies .... Blocked", even though not all third party cookies are blocked.
Michelle, please confirm if this is okay.  Thanks!
Flags: needinfo?(mheubusch)
Bryan, please also confirm.
Flags: needinfo?(bbell)
Or should it be "Tracking Cookies"
Priority: -- → P1
Please review
Flags: needinfo?(bmikel)
Whiteboard: [privacy-panel-64][triage] → [privacy-panel]
I think for now we should say Tracking Cookies for behavior 4 because in the intro paragraph we say all the content we are blocking is third-party, so this is not necessary to specify again.
Flags: needinfo?(mheubusch)
Flags: needinfo?(bmikel)
Bryan confirmed "Tracking Cookies" for behavior 4.
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
(In reply to mheubusch from comment #5)
> I think for now we should say Tracking Cookies for behavior 4 because in the
> intro paragraph we say all the content we are blocking is third-party, so
> this is not necessary to specify again.

Hmm, FWIW there is no intro text here.  This is for the Control Centre, not Preferences...  :-/
We should still call it Tracking Cookies in the Control Center - thanks for confirming.  I realize that this isn't wholly consistent with Prefs but can rationalize that Tracking Cookies is a subset and if Third Party Cookie Blocking is enabled, this will be true if only Tracking are blocked or if All-Third party (which include tracking) are blocked.
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8fc40677cc0e
Show "Tracking Cookies" label in the control center when only tracking cookies are blocked. r=Ehsan
https://hg.mozilla.org/mozilla-central/rev/8fc40677cc0e
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.