Closed Bug 1496244 Opened Last year Closed Last year

"Tracking Protection" string still appears in Exceptions Dialog under Content Blocking

Categories

(Firefox :: Protections UI, defect, P1)

63 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
firefox63 - wontfix
firefox64 --- verified

People

(Reporter: tanvi, Assigned: mkohler)

References

(Blocks 1 open bug)

Details

(Whiteboard: [privacy-panel])

Attachments

(2 files)

Under Content Blocking, click Exceptions.  The title and description both still say "Tracking Protection".  This is in Nightly and Beta.
Priority: -- → P1
Whiteboard: [privacy-panel-64][triage] → [privacy-panel]
Michelle said these string changes are fine.  Johann, can you take this for 64?
Flags: needinfo?(jhofmann)
Sorry, the string changes are just s/Tracking Protection/Content Blocking/
Assignee: nobody → me
Status: NEW → ASSIGNED
Flags: needinfo?(jhofmann)
Is this something we might want to uplift for 63 release?
Flags: needinfo?(tanvi)
Flags: needinfo?(me)
I'm in no position to make a decision here.
Flags: needinfo?(me)
From email, sounds like this is fine to stay in 64. Thanks!
It would be great to get into 63, because Firefox 63 won't have "Tracking Protection" anymore.  But this is probably not a frequently used piece of UI, so having the wrong text for 1 release is probably okay.

That being said, I think we do need to keep the old "Tracking Protection" strings in product in cases where browser.contentblocking.ui.enabled is set to false.  Johann, please take a look at this patch and advise.
Flags: needinfo?(tanvi)
Keywords: checkin-needed
Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5aff488dd9e9
Change 'Tracking Protection' to 'Content Blocking' in Exceptions Dialog under Content Blocking r=flod,johannh
Keywords: checkin-needed
Backed out changeset 5aff488dd9e9 (bug 1496244) for Browser chrome failures in browser/components/preferences/in-content/tests/browser_search_subdialogs_within_preferences_2.js

Log:
https://treeherder.mozilla.org/logviewer.html#?job_id=205513124&repo=autoland&lineNumber=22607

 TEST-PASS | browser/components/preferences/in-content/tests/browser_search_subdialogs_within_preferences_2.js | Element should not be null, when checking visibility - 
05:51:40     INFO - Buffered messages finished
05:51:40     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_search_subdialogs_within_preferences_2.js | Should not be in search results - 
05:51:40     INFO - Stack trace:
05:51:40     INFO - chrome://mochitests/content/browser/browser/components/preferences/in-content/tests/head.js:is_element_hidden:15
05:51:40     INFO - chrome://mochitests/content/browser/browser/components/preferences/in-content/tests/head.js:evaluateSearchResults:148
05:51:40     INFO - chrome://mochitests/content/browser/browser/components/preferences/in-content/tests/browser_search_subdialogs_within_preferences_2.js:null:26
05:51:40     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1093
05:51:40     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1084
05:51:40     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:986
05:51:40     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
05:51:40     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_search_subdialogs_within_preferences_2.js | Element should not be null, when checking visibility - 
05:51:40     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_search_subdialogs_within_preferences_2.js | Should not be in search results - 

Push with failures:
https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=5aff488dd9e943c985dc7ffed98d26e46c71dfab

Backout:
https://hg.mozilla.org/integration/autoland/rev/4d2fbdbead3a58f724be4cba4c5fa00fbb4f5207
Flags: needinfo?(me)
Yeah, stupid me, missed that in the try run. Sorry!
Flags: needinfo?(me)
Johann, the latest patch should fix the problem. However due to https://bugzilla.mozilla.org/show_bug.cgi?id=1499232 and me not having the right SSH key for try on this laptop made it impossible for me to test it correctly. Would be great if you could push it for me.
Flags: needinfo?(jhofmann)
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fd7038210e70
Change 'Tracking Protection' to 'Content Blocking' in Exceptions Dialog under Content Blocking r=flod,johannh
Flags: needinfo?(jhofmann)
https://hg.mozilla.org/mozilla-central/rev/fd7038210e70
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
I have reproduced this issue using Firefox 64.0a1 (2018.10.03) on Ubuntu 18.04 x64.
I can confirm this issue is fixed, I verified using Firefox 64.0b3 on Ubuntu 18.04 x64, Win 10 x64 and Mac OS X 10.13.6.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.