Closed Bug 1496532 Opened Last year Closed Last year

Content script sometimes runs in pre-allocated new tab page

Categories

(WebExtensions :: General, defect, P3)

defect

Tracking

(firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: zombie, Assigned: zombie)

References

Details

Attachments

(2 files)

This seems similar to bug 1491994, but happens even with the default new page, which probably gets pre-allocated in the wrong process.
This is not a big deal, but we should try to prevent it if possible, I'll try to figure it out.
Priority: -- → P3
Pushed by tomica@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/bde20ce03a12
Stop running content scripts on preallocated new tab page r=aswan
Assignee: nobody → tomica
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/bde20ce03a12
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Can you give more details please?

I'm not familiar with either raptor or android, nor how this change could affect anything on platforms which don't have e10s.

Also, from my understanding, tier 3 tests are not sufficient reason for backouts.
(In reply to Bob Clary [:bc:] from comment #6)
> This broke raptor on Android. See bug 1492117 comment 5. Please back it out
> or fix the issue soon.

Lets start by establishing what actually broke here.  Does raptor on Android run with browser.tabs.remote.autostart set to True?
Flags: needinfo?(bob)
The raptor tests on pixel 2 are tier 2.

rwood can help more with the details of what might be the problem, but I think it may be related to how the raptor extension starts from about:blank then loads the benchmark test pages. The source is located in https://searchfox.org/mozilla-central/source/testing/raptor.

It isn't clear to me about the preference. I'll check.
Attached file user.js
These are the prefs used in raptor. It does have
user_pref("browser.tabs.remote.autostart", true);
Flags: needinfo?(bob)
So enabling e10s on Android is uncharted territory.  Is it deliberate that raptor tests run in a non-standard configuration?
Flags: needinfo?(bob)
Flags: needinfo?(bob) → needinfo?(rwood)
snorp: Do you have ideas about this related to e10s?
Flags: needinfo?(snorp)
we should clarify if we are running fennec vs geckoview, I believe we are running geckoview for speedometer on pixel2
I'm not sure what I need to clarify? GeckoView uses e10s (1 content process), but Fennec does not.

Extensions are not publicly supported by GeckoView, but we have been able to use them to run mochitest and things like that.
Flags: needinfo?(snorp)
(In reply to Andrew Swan [:aswan] from comment #11)
> So enabling e10s on Android is uncharted territory.  Is it deliberate that
> raptor tests run in a non-standard configuration?

Raptor inherits a standard set of prefs used by performance tests, which includes the e10s one :bc noted in Coment 10:

https://searchfox.org/mozilla-central/rev/1ce4e8a5601da8e744ca6eda69e782318afab54d/testing/profiles/perf/user.js#38

Then for Raptor specifically we also set these additional prefs:

https://searchfox.org/mozilla-central/source/testing/profiles/raptor/user.js

Yes Raptor is running speedometer on geckoview (via the example app).
Flags: needinfo?(rwood)
:aswan/:zombie, if you have recommendations for us to try fixing the test on android, we are happy to help out, this is a priority test for gathering perf metrics on android, we are 2.5 days without data now (tier-2 for pixel2 devices, and tier-3 for motorola g5).  Do we need to change something in the web extension ( https://searchfox.org/mozilla-central/source/testing/raptor/webext/raptor )?
Flags: needinfo?(tomica)
Flags: needinfo?(aswan)
We can fix this on the webextensions side, the issue is that the patch doesn't cope with platforms that have e10s enabled but do not have out-of-process extensions enabled.  Apparently geckoview is such a platform...
zombie is out today, I'll try to work up a patch.
Flags: needinfo?(tomica)
Flags: needinfo?(aswan)
(In reply to Andrew Swan [:aswan] from comment #17)

Thanks Andrew!
Depends on: 1498311
Depends on: 1498636
No longer depends on: 1498636
Can you please add some STRs here and a test webextension if possible?
Flags: needinfo?(tomica)
This is hard to reproduce reliably.
Flags: needinfo?(tomica) → qe-verify-
Blocks: 1427585
You need to log in before you can comment on or make changes to this bug.