Closed Bug 1496608 Opened Last year Closed Last year

ContentParent leaks GeckoChildProcessHost on launch failure

Categories

(Core :: IPC, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: jld, Assigned: jld)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

ContentParent disposes of its GeckoChildProcessHost instance in ActorDestroy, but that's never called if the process launch failed.

I've confirmed that it leaks by editing the code to introduce artificial launch failures and watchpointing the vtable pointer; there should be a better way to do that.
Pushed by jedavis@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8ede2ebe6b7a
Don't leak GeckoChildProcessHost when a content process fails to launch. r=mccr8
(In reply to Andreea Pavel [:apavel] from comment #3)
> Jed: i backed out the whole push because i was not sure what bug
> specifically started this.

Thanks for the backout and the links.  (For reference, the assertion that's failing was added in bug 1446161, but I think the reason it's failing is bug 1487287.  There's also a Mac failure related to Web Replay, which definitely is bug 1487287.)
Flags: needinfo?(jld)
Pushed by jedavis@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1b92017b4865
Don't leak GeckoChildProcessHost when a content process fails to launch. r=mccr8
https://hg.mozilla.org/mozilla-central/rev/1b92017b4865
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.