Volume slider in HTML5 audio player is verbalized as generic "slider" and not "volume slider" in NVDA.

VERIFIED FIXED in Firefox 64

Status

()

defect
P3
normal
VERIFIED FIXED
11 months ago
10 months ago

People

(Reporter: charleyroy, Assigned: Gijs)

Tracking

({access})

62 Branch
mozilla64
Points:
---

Firefox Tracking Flags

(firefox64 verified)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

Steps to reproduce:

Pre-step: Enable NVDA screen reader.

Step 1: Go to http://jsfiddle.net/sqdkxy4z/ (or set up a native HTML5 audio with controls)
Step 2: Click / focus on the volume player.


Actual results:

The verbalization just reads "slider".


Expected results:

The verbalization should give an indication that this is some kind of volume slider.
Component: Untriaged → Video/Audio Controls
Keywords: access
Product: Firefox → Toolkit
Does NVDA read the state (value) of the slider if it is manipulated? That is, is this just a question of putting an aria-label (accessible name) on the slider, or do we need to also provide information about the volume state ourselves?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(charleyroy)
Priority: -- → P3
I believe adding an aria-label to the slider to make it clear that this is controlling volume would solve the issue.
Flags: needinfo?(charleyroy)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
See Also: → 1496851
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ba07c543cc93
add label to volume slider, r=MarcoZ
https://hg.mozilla.org/mozilla-central/rev/ba07c543cc93
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
I reproduced this issue on Windows 10 with Fx 64.0a1 (20181005220146). 
The issue is fixed on Fx 64.0b3 (20181022150107) on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.