Closed Bug 1497056 Opened 4 years ago Closed 4 years ago

Justify text in reader view

Categories

(Toolkit :: Reader Mode, enhancement, P3)

62 Branch
enhancement

Tracking

()

RESOLVED WONTFIX

People

(Reporter: dev, Unassigned)

Details

(Keywords: uiwanted, Whiteboard: [reader-mode-firefox-integration])

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0

Steps to reproduce:

I activated the reader view on a page with many lines of text (e.g. news article).


Actual results:

The text is left aligned (at least in English language).


Expected results:

I think, it looks better and it was better to read, when it is justified.
Severity: normal → enhancement
Component: Untriaged → Reader Mode
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
Priority: -- → P3
Whiteboard: [reader-mode-firefox-integration]
Fully Justified type is generally harder to read and is done to help solidify the verticle separations between columns in multi-column layouts. Since we don't have multiple columns I would recommend not fully justifying type in Reader Mode.
(In reply to bbell from comment #1)
> Fully Justified type is generally harder to read and is done to help
> solidify the verticle separations between columns in multi-column layouts.
> Since we don't have multiple columns I would recommend not fully justifying
> type in Reader Mode.

Marking wontfix per Bryan's comment.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
I disagree with the notion that justified text is always harder to read, and that it's only used in multi-column layouts. I personally prefer justified alignment for longer texts, and most printed books use justified text alignment despite being single-column. Documents written in LaTeX are fully justified by default.

Since most text on the web is left-aligned left-aligning is a good default and should remain, but I see no reason not to give the user the option to justify the text should they choose to. Alignment options could be presented in the type control menu, where other similar options can be found.

Below is a working mockup I threw together (centering and right-alignment could be excluded, I don't know if there is interest in that)
https://i.imgur.com/e7pRYK3.png
You need to log in before you can comment on or make changes to this bug.