feature request: disable window.open JS calls

VERIFIED DUPLICATE of bug 9307

Status

()

Core
JavaScript Engine
P3
enhancement
VERIFIED DUPLICATE of bug 9307
19 years ago
16 years ago

People

(Reporter: sean, Assigned: Mike McCabe)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Everyone I know hates popup windows on free web hosting sites and even
commercial pages (which occasionally popup announcements or surveys).  I would
like to be able to disable just window.open method calls without disabling all
of JavaScript interpretation.
I guess you could argue this shouldn't be done because some users of
window.open use it for ads, and they need revenue...  But no one can force
users to read ads, this just saves us from having to wear out mouse buttons
clicking on close buttons all the time.  Popups in general are rude, much more
inconvenient if not as "damaging" to the web as frames.  I think we should be
able to kill them.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 9307 ***

Comment 2

18 years ago
Yes, it's a dup.  VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.