Closed Bug 1497222 Opened Last year Closed Last year

Crash in mozilla::dom::PaymentResponse_Binding::get_details

Categories

(Core :: DOM: Web Payments, defect, critical)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1497215
Tracking Status
firefox63 --- unaffected
firefox64 --- affected

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-2b1de557-cefc-4b59-ac9d-ebde30181008.
=============================================================

Seen while looking at Windows crash stats - 7 crashes/2 installs so far. Crashes started using 20181007220217: https://bit.ly/2zXF6uw

URLs seem to be some variation of https://rsolomakhin.github.io/pr/multi/ 

Top 10 frames of crashing thread:

0 xul.dll static bool mozilla::dom::PaymentResponse_Binding::get_details dom/bindings/PaymentResponseBinding.cpp:136
1 xul.dll static bool mozilla::dom::PaymentResponse_Binding::CollectJSONAttributes dom/bindings/PaymentResponseBinding.cpp:699
2 xul.dll static bool mozilla::dom::PaymentResponse_Binding::toJSON dom/bindings/PaymentResponseBinding.cpp:529
3 xul.dll mozilla::dom::binding_detail::GenericMethod<mozilla::dom::binding_detail::NormalThisPolicy, mozilla::dom::binding_detail::ThrowExceptions> dom/bindings/BindingUtils.cpp:3315
4 xul.dll js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:553
5 xul.dll static bool InternalCall js/src/vm/Interpreter.cpp:607
6 xul.dll js::Call js/src/vm/Interpreter.cpp:626
7 xul.dll static bool PreprocessValue<JS::Handle<jsid> > js/src/builtin/JSON.cpp:306
8 xul.dll js::Stringify js/src/builtin/JSON.cpp:871
9 xul.dll json_stringify js/src/builtin/JSON.cpp:1085

=============================================================
Looks as if this is a dupe of the bug filed by SV, Bug 1497215.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1497215
You need to log in before you can comment on or make changes to this bug.