Closed Bug 1497268 Opened Last year Closed Last year

Crash in android.database.CursorWindowAllocationException: at android.database.CursorWindow.<init>(CursorWindow.java)

Categories

(Firefox for Android :: General, defect, critical)

Firefox 62
Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 760394
Tracking Status
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- fix-optional

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-e5d3156b-59b0-4a04-8ee4-b80cd0181008.
=============================================================

Not sure if this is a signature change due to Bug 1496599, but this signature shows up as #2 overall in 62.0.3: https://bit.ly/2OEFOoX. 3606 crashes in 62.0.3 so far.

android.database.CursorWindowAllocationException: Cursor window allocation of 2048 kb failed. # Open Cursors=1 (# cursors opened by this proc=1) appears in the Java stack trace

Java stack trace:

android.database.CursorWindowAllocationException
	at android.database.CursorWindow.&lt;init&gt;(CursorWindow.java:109)
	at android.database.CursorWindow.&lt;init&gt;(CursorWindow.java:100)
	at android.database.AbstractWindowedCursor.clearOrCreateWindow(AbstractWindowedCursor.java:198)
	at android.database.sqlite.SQLiteCursor.clearOrCreateWindow(SQLiteCursor.java:301)
	at android.database.sqlite.SQLiteCursor.fillWindow(SQLiteCursor.java:139)
	at android.database.sqlite.SQLiteCursor.getCount(SQLiteCursor.java:133)
	at android.content.ContentResolver.query(ContentResolver.java:489)
	at android.content.ContentResolver.query(ContentResolver.java:413)
	at org.mozilla.gecko.db.LocalBrowserDB.filterAllSites(LocalBrowserDB.java:684)
	at org.mozilla.gecko.db.LocalBrowserDB.filter(LocalBrowserDB.java:744)
	at org.mozilla.gecko.home.SearchLoader$SearchCursorLoader.loadCursor(SearchLoader.java:102)
	at org.mozilla.gecko.home.SimpleCursorLoader.loadInBackground(SimpleCursorLoader.java:61)
	at org.mozilla.gecko.home.SimpleCursorLoader.loadInBackground(SimpleCursorLoader.java:42)
	at android.support.v4.content.AsyncTaskLoader.onLoadInBackground(AsyncTaskLoader.java:296)
	at android.support.v4.content.AsyncTaskLoader$LoadTask.doInBackground(AsyncTaskLoader.java:54)
	at android.support.v4.content.AsyncTaskLoader$LoadTask.doInBackground(AsyncTaskLoader.java:42)
	at android.support.v4.content.ModernAsyncTask$2.call(ModernAsyncTask.java:128)
	at java.util.concurrent.FutureTask.run(FutureTask.java:237)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1112)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:587)
	at java.lang.Thread.run(Thread.java:841)
This appears to be a signature change due to Bug 1496599.
bug 760394 has the older signatures for this
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 760394
You need to log in before you can comment on or make changes to this bug.