Crash in <name omitted> | <name omitted> | mozilla::dom::DeferredFinalizerImpl<T>::DeferredFinalize

RESOLVED FIXED in Firefox 67

Status

()

defect
--
critical
RESOLVED FIXED
10 months ago
5 months ago

People

(Reporter: marcia, Assigned: bhackett)

Tracking

({crash})

Trunk
mozilla67
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 wontfix, firefox65 wontfix, firefox66 wontfix, firefox67 fixed)

Details

(crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is
report bp-a8cf9875-29a5-451c-8ec6-96dd60181004.
=============================================================

Seen while looking at nightly crash stats - some Mac and Windows crashes: https://bit.ly/2pPAp0h and https://bit.ly/2Pho1RA.

One comment "Testing WebReplay on Invision "

Top 10 frames of crashing thread:

0  @0x12d2c7018 
1 XUL <name omitted> netwerk/base/nsInputStreamChannel.h:28
2 XUL <name omitted> xpcom/ds/nsHashPropertyBag.cpp:250
3 XUL mozilla::dom::DeferredFinalizerImpl<nsISupports>::DeferredFinalize xpcom/base/nsCOMPtr.h:313
4 XUL mozilla::IncrementalFinalizeRunnable::ReleaseNow xpcom/base/CycleCollectedJSRuntime.cpp:1373
5 XUL mozilla::CycleCollectedJSRuntime::GCCallback xpcom/base/CycleCollectedJSRuntime.cpp:1515
6 XUL js::gc::GCRuntime::maybeCallGCCallback js/src/gc/GC.cpp:1878
7 XUL js::gc::GCRuntime::gcCycle js/src/gc/GC.cpp:7836
8 XUL js::gc::GCRuntime::collect js/src/gc/GC.cpp:8121
9 XUL js::gc::GCRuntime::startGC js/src/gc/GC.cpp

=============================================================

Another recent nightly Mac crash has this URL - https://firefox-dev.tools/debugger-examples/examples/todomvc/

This crash continues to be a problem, and is the main source of crashes when recording/replaying. These have all been in the nsHashPropertyBag destructor, and while I don't know what the problem is or whether it is specific to this class, it would be nice to avoid the crash by just leaking the bag and its contents, as the associated patch does. (We already leak memory when recording/replaying, e.g. the cycle collector is disabled.)

Pushed by bhackett@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b7141d2c750d
Avoid destroying nsHashPropertyBag when recording/replaying, r=mccr8.
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Assignee: nobody → bhackett1024
You need to log in before you can comment on or make changes to this bug.