Closed Bug 1497443 Opened Last year Closed Last year

Text on custom urls Buttons in about:preferences#home page overflows

Categories

(Firefox :: Preferences, defect, P1, minor)

defect

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- verified

People

(Reporter: cfogel, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

[Affected versions]:
- 62.0.3, 63.0b12, 64.0a1 (2018-10-08) 

[Affected platforms]:
- win 10x64, Ubuntu 16.04, macOS 10.13

[Steps to reproduce]:
1. Launch Firefox;
2. Access about:preferences#home
3. Click the dropdown for the Homepage and new windows option;
4. Click on Custom URLs...
5. Grab the browser and resize to shrink its width.

[Expected result]:
- content is properly displayed;
- not sure of the proper behavior, but probably the button width should remain the same to contain the text;

[Actual result]:
- the following buttons are changing width to adjust for resize but text is overflowing: [Use Current Pages], [Use Bookmark...]

[Regression range]:
- introduced with bug 1417155

[Additional notes]:
- attached screenshot with the issue;
This is caused by the buttons having -moz-box-flex (flex=1 attribute) and a defined min-width ( https://searchfox.org/mozilla-central/source/toolkit/themes/osx/global/button.css#12 , https://searchfox.org/mozilla-central/source/toolkit/themes/linux/global/button.css#16, https://searchfox.org/mozilla-central/source/toolkit/themes/windows/global/button.css#16 ), which in XUL means they can be resized as part of flex. There's a trivial fix for this, I'll just put up a patch.

While this may have regressed as part of bug 1417155, that's only because this stuff is now in its own column so there's less available width in the first place. I bet in locales with longer labels this would have been reproducible in the old layout, prior to bug 1417155.
Assignee: nobody → gijskruitbosch+bugs
Blocks: 1417155
Status: NEW → ASSIGNED
Priority: -- → P1
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/59b646e9e899
set min-width to auto for flexed buttons in the prefs, r=jaws
Blocks: 1500589
https://hg.mozilla.org/mozilla-central/rev/59b646e9e899
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Verified with 64.0a1 (2018-10-21)  on macOS_10.14, Ubuntu_16.04, Win_10x64.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.