Closed Bug 1497563 Opened 11 months ago Closed 9 months ago

Crash in gfxFontGroup::AddFamilyToFontList

Categories

(Core :: Layout: Text and Fonts, defect, critical)

63 Branch
Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- fixed
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- fixed
firefox65 --- fixed

People

(Reporter: marcia, Assigned: jfkthame)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-992b4607-b61d-4f31-a62a-7b7d60181009.
=============================================================

Seen while looking at release crash stats: https://bit.ly/2NvzD1G. Mac crash that appears to be affecting 10.14 users primarily. Users mention lots of tab crashes:

*keep getting Gah. Your tab just crashed I am unable to use my browser 
*Every time I open a new tab it crashes! Already deleted all cache, cookies, etc., ad relaunched Firefox, but it's still happening. Next I'll try creating a new profile. 

Although this is not huge volume now, it will be interesting to track this as 10.14 continues to roll out. No crashes seen on 64, but seen on 63 and 62.

Top 10 frames of crashing thread:

0 XUL gfxFontGroup::AddFamilyToFontList gfx/thebes/gfxTextRun.cpp:1861
1 XUL gfxFontGroup::BuildFontList gfx/thebes/gfxTextRun.cpp:1826
2 XUL mozilla::sCRLFTabMask 
3 XUL AppendUTF16toUTF8 xpcom/string/nsCharTraits.h:540
4 XUL CopyUTF16toUTF8 xpcom/string/nsReadableUtils.cpp:139
5  @0x1145491af 
6 XUL gfxFontGroup::gfxFontGroup gfx/thebes/gfxTextRun.cpp:1786
7 libmozglue.dylib BaseAllocator::malloc memory/build/mozjemalloc.cpp:3020
8  @0x1141e1557 
9 XUL gfxPlatformMac::CreateFontGroup gfx/thebes/gfxPlatformMac.cpp:161

=============================================================
Seems very similar to bug 1493743; I suspect it may be the same underlying issue.
See Also: → 1493743
Duplicate of this bug: 1502768
(In reply to Jonathan Kew (:jfkthame) from comment #1)
> Seems very similar to bug 1493743; I suspect it may be the same underlying
> issue.

No crashes in v64 (when bug 1493743 was fixed). So presumably this was fixed by the fix for bug 1493743.
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Bug 1493743 is marked as esr60:unaffected, but this crash signature is showing up there. Is that patch likely to help on that branch too?
Assignee: nobody → jfkthame
Flags: needinfo?(jfkthame)
Target Milestone: --- → mozilla65
I think that's quite likely, yes.
Flags: needinfo?(jfkthame)
Depends on: 1493743
You need to log in before you can comment on or make changes to this bug.