Closed Bug 1497571 Opened Last year Closed Last year

Crash in <name omitted> | <name omitted> | nsCSPContext::SetEventListener

Categories

(Core :: XPCOM, defect, critical)

62 Branch
Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1498510
Tracking Status
firefox64 --- affected

People

(Reporter: lizzard, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-1d800db2-f167-41c2-bd5f-edda70181008.
=============================================================


This crash signature started showing up in the 20180927100044 nightly build.


Top 10 frames of crashing thread:

0 libmozglue.dylib <name omitted> mozglue/misc/Mutex_posix.cpp:117
1 XUL <name omitted> xpcom/threads/Mutex.h:60
2 XUL nsCSPContext::SetEventListener xpcom/base/nsCOMPtr.h:413
3 XUL mozilla::dom:: dom/workers/WorkerPrivate.cpp:3456
4 XUL mozilla::dom::WorkerRunnable::Run dom/workers/WorkerRunnable.cpp:380
5 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1231
6 XUL NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:530
7 XUL mozilla::dom::WorkerPrivate::DoRunLoop dom/workers/WorkerPrivate.cpp:3300
8 XUL mozilla::dom::workerinternals:: dom/workers/RuntimeService.cpp:2762
9 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1231

=============================================================
This crash signature only shows up (so far) on OS X 10.12 and 10.13.
Looks as if the Moz Crash Reason for all crashes is MOZ_CRASH(mozilla::detail::MutexImpl::~MutexImpl: pthread_mutex_destroy failed). Looks as if code was touched in Bug 1490165 in the 64 cycle. ni on :baku.
Flags: needinfo?(amarchesini)
The crash sounds to be potentially worse than the fix in Bug 1490165. I just chatted with baku and we are considering adding a pref around the code in question.

What are the crash stats? Is this problem within this bug very likely to crash Firefox?
In 63b13, we only have 3 crashes, and in 64 it looks like 3 as well. No comments and no URLs at the moment. So definitely not a high volume crash.
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1498510
You need to log in before you can comment on or make changes to this bug.