Closed Bug 1497605 Opened 3 years ago Closed 3 years ago

Cherry pick clang 339424 to make -fcrash-diagnostics-dir work for clang-cl

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1512921

People

(Reporter: ted, Unassigned)

Details

I have a patch in bug 1477306 that's useful but to use it for Windows builds it requires a patch that didn't make the clang 7 release. Cherry-picking it into our clang-cl toolchain would let us use `-fcrash-diagnostics-dir` which would be very useful for dealing with compiler errors in CI.

https://github.com/llvm-mirror/clang/commit/8c7ddf2e8931f8aeebd6cb80701bd58cdbc31c7a
This was merged into 7.0.1 which I assume we'll pick up when it's released, so if nobody gets around to this before then, it ought to solve itself.
No longer blocks: 1477306
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1512921
You need to log in before you can comment on or make changes to this bug.