Double-Zoom puts title bar under menu bar

RESOLVED FIXED

Status

()

Core
XUL
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Chris Pepper, Assigned: jag (Peter Annema))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Hitting the green zoom button once fills the screen (except for the left edge).
This is sub-optimal, since it often wastes space, but discussed in another bug.

Much worse, and new since RC1, hitting the zoom button again goes back to the
original dimensions, but slides the window back up so that its title bar is
exactly covered by the menu bar. This means the window can't be moved, or closed
with the mouse, or zoomed.

Comment 1

16 years ago
Chris, what Build ID are you reporting this against?

Can you reproduce this problem using a new Mozilla user profile?

WorksForMe using FizzillaCFM/2002052918. A second activiation of the Zoom widget
returns the window to its' original dimensions and position.
(Reporter)

Comment 2

16 years ago
Created attachment 86912 [details]
Screenshot showing the window in an impossible position.

It's impossible to manually move a window under the menu bar like this in MOSX

Comment 3

16 years ago
Chris, still awaiting your response to Comment #1.

-->XP Toolkit/Widgets for now.
Assignee: Matti99 → jaggernaut
Component: Browser-General → XP Toolkit/Widgets
QA Contact: imajes-qa → jrgm

Comment 4

16 years ago
zooming twice works for me in OSX trunk 20030102, except that the window
repaints badly sometimes (probably the good old gray regions bug). It neither
fills the screen nor slides under the menu bar.
(Reporter)

Comment 5

16 years ago
I haven't seen this behavior since 10.2.3 (with "Mozilla/5.0 (Macintosh; U; PPC
Mac OS X; en-US; rv:1.2.1) Gecko/20021130").

Unfortunately, Mozilla won't zoom properly or stay on my secondary monitor.
Reporting as a new bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.