Use fluent for Update History in Update section of Preferences

RESOLVED FIXED in Firefox 65

Status

()

P3
normal
RESOLVED FIXED
6 months ago
5 months ago

People

(Reporter: songqing, Assigned: songqing)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

Steps to reproduce:

This bug converts the Update History in Update section of Preferences, as well as the searchkeywords attribute of Show  
Update History button (https://searchfox.org/mozilla-central/source/toolkit/mozapps/update/content/history.xul) to using Fluent for localization.
(Assignee)

Updated

6 months ago
Blocks: 1486917
Component: Untriaged → Preferences
Priority: -- → P3
(Assignee)

Updated

6 months ago
Duplicate of this bug: 1497687
Attachment #9015712 - Attachment description: Bug 1497694 - Migrate history.xul and main.xul to use fluent for localization → Bug 1497694 - Migrate Update History in Update section of Preferences to use fluent for localization
Depends on: 1317336
Attachment #9015712 - Attachment description: Bug 1497694 - Migrate Update History in Update section of Preferences to use fluent for localization → Bug 1497694 - Migrate Update History in Update section of Preferences to use Fluent for localization

Comment 3

5 months ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e66bbfad641e
Migrate Update History in Update section of Preferences to use Fluent for localization r=Gijs,flod,zbraniecki,jaws
Assignee: nobody → songqing
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

5 months ago
Backout by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/da119c04dff6
Backed out changeset e66bbfad641e for bc failures on browser_advanced_update.js. CLOSED TREE
You probably just want to test `deepEqual(document.l10n.getAttributes(elem), {id: ..., args: ...})` in that test.

Comment 6

5 months ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d328221048e2
Migrate Update History in Update section of Preferences to use Fluent for localization r=Gijs,flod,zbraniecki,jaws

Comment 7

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d328221048e2
Status: NEW → RESOLVED
Last Resolved: 5 months ago
status-firefox65: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
You need to log in before you can comment on or make changes to this bug.