Flickering effect on menu bar

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
6 months ago
2 months ago

People

(Reporter: daschilean, Assigned: sotaro)

Tracking

(Blocks: 1 bug, {regression})

64 Branch
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(geckoview62 unaffected, firefox-esr60 unaffected, firefox62 unaffected, firefox63 disabled, firefox64 disabled, firefox65 disabled, firefox66 verified, firefox67 verified)

Details

(URL)

Attachments

(1 attachment)

Posted video FlickeringEffect.mp4
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0 
Build ID: 20181009220508

[Affected versions]:
Nightly 64.0a1 (2018-10-09) (64-bit) and Nightly 64.0a1 (2018-10-09) (32-bit)

[Affected platforms]:
Windows 10 x86, Windows 10 x64

[Steps to reproduce]:
1. Launch Firefox with a new profile
2. Type about:config
3. Set gfx.webrender.all.qualified =  true
4. Navigate to http://www.playmag.fr/heroesoftomorrow
5. Switch between "ALOY" and "KARA" option from the menu bar

[Expected result]:
The image should be displayed without any flickering effect.

[Actual result]:
Flickering effect is encountered after switching between "ALOY" and "KARA" from the top menu.
mozregression --good 2018-07-01 --bad 2018-10-09 --pref gfx.webrender.all:true -a http://www.playmag.fr/heroesoftomorrow
> 15:50.42 INFO: Last good revision: 8b5693e79dfd980f754bf04c06f1e1f6da5514fe
> 15:50.42 INFO: First bad revision: 6ea17dfcb278cbc22891a77d3e1baa82614c38ab
> 15:50.42 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8b5693e79dfd980f754bf04c06f1e1f6da5514fe&tochange=6ea17dfcb278cbc22891a77d3e1baa82614c38ab

> 6ea17dfcb278	Jeff Muizelaar — Bug 1477505. Update webrender to commit e850fbd2e0e60a8de76c2d2464f0fa27316d5949

Regression range: https://github.com/servo/webrender/compare/c2c5aaebdd6df22ce13941c1a4b16ef47eaa9f7b...e850fbd2e0e60a8de76c2d2464f0fa27316d5949

Probably servo/webrender#2926: Avoid always reuploading blob images.
Blocks: 1477505, 1386669
status-firefox62: --- → unaffected
status-firefox63: --- → disabled
status-firefox-esr60: --- → unaffected
status-geckoview62: --- → unaffected
Keywords: regression
OS: Windows 10 → All
Priority: -- → P3
Marking fix-optional for 64. We could still take a patch for 65, and if it's verified and doesn't seem risky, could still take fixes for 64 as well.
status-firefox64: affected → fix-optional
(Assignee)

Comment 3

3 months ago
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #1)
> mozregression --good 2018-07-01 --bad 2018-10-09 --pref
> gfx.webrender.all:true -a http://www.playmag.fr/heroesoftomorrow
> > 15:50.42 INFO: Last good revision: 8b5693e79dfd980f754bf04c06f1e1f6da5514fe
> > 15:50.42 INFO: First bad revision: 6ea17dfcb278cbc22891a77d3e1baa82614c38ab
> > 15:50.42 INFO: Pushlog:
> > https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8b5693e79dfd980f754bf04c06f1e1f6da5514fe&tochange=6ea17dfcb278cbc22891a77d3e1baa82614c38ab
> 
> > 6ea17dfcb278	Jeff Muizelaar — Bug 1477505. Update webrender to commit e850fbd2e0e60a8de76c2d2464f0fa27316d5949
> 


When I checked with mozregression, a result was different like the following.

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8984f6868e572079cc991492124ba99747f0f681&tochange=80efe717b563f329a2261a8d23f4ebbc470c432f

In this case, Bug 1494164 might be similar.
(Assignee)

Updated

3 months ago
See Also: → bug 1494164
(Assignee)

Updated

3 months ago
Assignee: nobody → sotaro.ikeda.g
Still reproducible on Win10/GTX1060.
(Assignee)

Comment 5

3 months ago
A patch in Bug 1505363 address the problem for me.
(Assignee)

Updated

3 months ago
Depends on: 1505363
(Assignee)

Comment 6

3 months ago

I confirmed that the problem was addressed on latest nightly.

Yes, thank you!

Status: NEW → RESOLVED
Last Resolved: 3 months ago
status-firefox64: fix-optional → disabled
status-firefox65: --- → disabled
status-firefox66: --- → fixed
Resolution: --- → FIXED

Comment 8

2 months ago

Hi, This issue is Verified as Fixed in the Latest Nightly 67.0a1 (2019-02-07) as well as Beta 66.0b5, I will mark this issue accordingly.

Status: RESOLVED → VERIFIED
status-firefox66: fixed → verified
status-firefox67: --- → verified
You need to log in before you can comment on or make changes to this bug.