Status

()

enhancement
RESOLVED FIXED
8 months ago
7 months ago

People

(Reporter: Nika, Assigned: qdot)

Tracking

(Blocks 2 bugs)

unspecified
mozilla65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

:qDot was wanting something like this, and I offered to throw together something really quickly.

This hasn't been heavily tested.
Assignee: nobody → kyle
Add bitflag types to XPIDL, allowing for typed enums in C++ instead of
using uintXX_t types. Javascript will still reflect bitflags as
interface level consts.

Depends on D8593
Attachment #9016110 - Attachment is obsolete: true
Attachment #9016110 - Attachment is obsolete: false
Attachment #9016110 - Attachment is obsolete: true
Attachment #9016781 - Attachment description: Bug 1498059 - Allow 8-bit unsigned consts in XPIDL → Bug 1498059 - Allow 8-bit unsigned consts in XPIDL; ,
Attachment #9016782 - Attachment description: Bug 1498059 - Add typed bitflags to XPIDL → Bug 1498059 - Add typed bitflags to XPIDL;
Attachment #9016783 - Attachment description: Bug 1498059 - Tests for bitfields in XPIDL → Bug 1498059 - Tests for bitfields in XPIDL;
Duplicate of this bug: 262000
Attachment #9016782 - Attachment description: Bug 1498059 - Add typed bitflags to XPIDL; → Bug 1498059 - Add CEnum types to XPIDL;
Attachment #9016783 - Attachment description: Bug 1498059 - Tests for bitfields in XPIDL; → Bug 1498059 - Tests for CEnums in XPIDL;
Summary: XPIDL typed bitflags → XPIDL typed CEnums

Comment 6

7 months ago
Pushed by kmachulis@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/edfa81173d9d
Allow 8-bit unsigned consts in XPIDL; , r=nika,froydnj
https://hg.mozilla.org/integration/autoland/rev/40c1a7f25008
Add CEnum types to XPIDL; r=nika,froydnj
https://hg.mozilla.org/integration/autoland/rev/58b76f270c22
Tests for CEnums in XPIDL; r=nika,froydnj

Comment 7

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/edfa81173d9d
https://hg.mozilla.org/mozilla-central/rev/40c1a7f25008
https://hg.mozilla.org/mozilla-central/rev/58b76f270c22
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.