[BiDi] Can't go back to text before a digit in text fields

RESOLVED DUPLICATE of bug 299239

Status

()

Core
Editor
--
major
RESOLVED DUPLICATE of bug 299239
16 years ago
13 years ago

People

(Reporter: Sagie Maoz, Assigned: smontagu)

Tracking

({intl})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: (lame) workaround in comment #8)

(Reporter)

Description

16 years ago
BuildID:    2002053012

In text fields and text areas, when typing Hebrew text with digits in the
middle, can't get the cursor back to the text before the digit using the arrow keys.

Reproducible: Always
Steps to Reproduce:
1. Focus on some text field.
2. Type a combined text: "hello 18 hello" (hello = Hebrew text).
3. Repeatedly press the right-arrow key.

Actual Results:  Cursor stops after digit and won't move right.

Expected Results:  Cursor should keep moving right when pressing the right-arrow
key.
(Assignee)

Comment 1

16 years ago
I can't reproduce this bug in either a left-to-right or a right-to-left text
field. Can you specify a site where you are seeing the problem?
(Reporter)

Comment 2

16 years ago
It is reproducable even in the "Additional Comments" textarea here in the bug's
page.
(Reporter)

Comment 3

16 years ago
NOTE: It only works with one digit in the middle. My example was wrong, try
"hello 8 hello".
(Assignee)

Comment 4

16 years ago
Why didn't you say so before? :-)

Confirming, accepting.
Assignee: mkaply → smontagu
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 5

16 years ago
This also happens in other text fields outside pages, e.g. the URL Bar and the
search bar in the mail client, so I'm not sure 'Browser' is the right product.

Comment 6

16 years ago
Editor: Core is probably the right component. however it seems like simon is 
going to work on this...

Updated

15 years ago
Blocks: 115711
Severity: normal → major
Component: Layout: BiDi Hebrew & Arabic → Editor: Core
Keywords: intl
OS: Windows 2000 → All
Hardware: PC → All
Summary: Can't go back to text before a digit in text fields → [BiDi] Can't go back to text before a digit in text fields
(Reporter)

Comment 7

13 years ago
Any word on this problem?
It's still there on newer versions..

Comment 8

13 years ago
(In reply to comment #7)
> Any word on this problem?

See Bug 207186 for other similar issues with handling the caret in BiDi texts.
And no, it's not likely that either of these bugs will be fixed in the
foreseeable future. 

Sad workaround: Use notepad.exe or IE6 to edit the text, then paste it back in
Mozilla/Firefox. That's what I and many others do. More details here:
http://mozilla.org.il/board/viewtopic.php?p=10025#10025

Prog.
Whiteboard: (lame) workaround in comment #8
This was re-filed as bug 299239. There's a patch there, so duplicating this one
to that.

*** This bug has been marked as a duplicate of 299239 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.