Closed Bug 1498112 Opened 3 years ago Closed 2 years ago

Single clicking the Back button after performing a search action with Bing, refreshes the page instead of redirecting the user to the previous page

Categories

(Core :: DOM: Navigation, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1528958
Tracking Status
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- wontfix
firefox78 --- wontfix

People

(Reporter: Anca, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

Attached video screencast issue.mp4
[Affected versions]: 
- 62.0.3 (20181001155545)
- 63.0b13 (20181008155858)
- 64.0a1 (20181009220508)

[Affected platforms]:
- Ubuntu 16.04 x64
- Windows 10 x64
- Windows 7 x64
- macOS 10.13

[Steps to reproduce]:
 Preconditions:
- Make sure no other Bing search was performed before, this behavior occurs only for the first search action

1. From about:preferences#search set Bing as Default search engine 
2. Open a new tab
3. Execute a search action as desired (Search bar, Address bar etc)
4. Click on the Back button

[Expected result]:
- The New tab page is displayed

[Actual result]:
- The search result page is refreshing, only double click returns the user to the New tab page

[Regression range]: 
- It is not a regression, I could reproduce the issue way back to Firefox 37.0a1.

[Additional Notes]:
- The issue is not reproducible for other search engines
- Chrome and Edge return the user on the home page with a single click, if Bing is set as default search engine
Happens when you visit bing.com and do a search there, so it's not related to our search access points in the UI, so moving this to document navigation.  Also as comment 0 says this doesn't happen in other browsers.
Component: Search → Document Navigation
Product: Firefox → Core
Could this be the same as bug 1447524?
Flags: needinfo?(anca.soncutean)
Most likely the issue described by me has the same root cause as bug 1447524, I could reproduce the two session history entries (see screenshot - https://drive.google.com/file/d/1WSSzXD6RizUKn0W4sqtD_7QkPCJt2U4R/view?usp=sharing), tested with latest Beta 64.0b4 (20181025233934) on Windows 10 x64 and Ubuntu 16.04 x86. 
The difference with the Bing search is that single clicking triggers no action regardless the numbers of the attempts (only double click returns the user to the initial page). Note also, that this has no influence on the number of history entries displayed, it remains constant (two entries) after the first single click on the “Back” button.
Flags: needinfo?(anca.soncutean)
Thanks for looking into it further, Anca.
Priority: -- → P3

This issue was reproducible on Windows 10 with Firefox Nightly version 74.0a1 (2020-01-14) (64-bit) / Beta version 73.0b4 (64-bit) and Release version 72.0.1 (64-bit). Marked as affected.

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

This issue is reproducible on Windows 10 with Firefox Nightly version 77.0a1 (2020-04-15) (64-bit)

Reproduced on latest Nightly 78.0a1 (2020-05-12) on macOS 10.14. Changed flags accordingly.

(We don't need to update affected flags for this bug for every new version, thanks)

We have a diagnosis in Bug 1528958, so let's dupe this to that.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1528958
You need to log in before you can comment on or make changes to this bug.