Closed Bug 1498200 Opened Last year Closed Last year

On latest m-c mach fails on macOS

Categories

(Firefox Build System :: Mach Core, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1498215

People

(Reporter: andi, Unassigned)

Details

On latest m-c, r491907, 'mach' fails on macOS, basically it doesn't matter the argument that is passed to 'mac', the outcome is the same:

 ./mach configure
Traceback (most recent call last):
  File "./mach", line 86, in <module>
    main(sys.argv[1:])
  File "./mach", line 78, in main
    mach = get_mach()
  File "./mach", line 68, in get_mach
    mach = check_and_get_mach(dir_path)
  File "./mach", line 42, in check_and_get_mach
    return load_mach(dir_path, mach_path)
  File "./mach", line 30, in load_mach
    return mach_bootstrap.bootstrap(dir_path)
  File "/Users/abpostelnicu/Projects/mozilla/mozilla-unified/build/mach_bootstrap.py", line 320, in bootstrap
    driver.load_commands_from_file(os.path.join(mozilla_dir, path))
  File "/Users/abpostelnicu/Projects/mozilla/mozilla-unified/python/mach/mach/main.py", line 267, in load_commands_from_file
    imp.load_source(module_name, path)
  File "/Users/abpostelnicu/Projects/mozilla/mozilla-unified/tools/lint/mach_commands.py", line 24, in <module>
    from scandir import scandir
  File "/Users/abpostelnicu/Projects/mozilla/mozilla-unified/build/mach_bootstrap.py", line 349, in __call__
    module = self._original_import(name, globals, locals, fromlist, level)
  File "/Users/abpostelnicu/Projects/mozilla/mozilla-unified/third_party/python/scandir/scandir.py", line 584, in <module>
    DirEntry_c = _scandir.DirEntry
AttributeError: 'module' object has no attribute 'DirEntry'
I don't understand why the revision you are pointing to is in svn.   I can't replicate your error with a recent revision of https://hg.mozilla.org/mozilla-central/ on Macosx
Flags: needinfo?(bpostelnicu)
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1498215
Bugzilla is strange, it automatically linked r491907 to an svn revision, thing that is wrong, that is a hg revision. Maybe because of the 'r' that prefixes 491907.
Flags: needinfo?(bpostelnicu)
Note that mercurial revision numbers are , mostly, useless. You want to use SHA-1s instead.
You need to log in before you can comment on or make changes to this bug.