javascript:close() closes the entire window

VERIFIED DUPLICATE of bug 103452

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 103452
16 years ago
9 years ago

People

(Reporter: mattitude80, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

When a tabbed page calls javascript:close(), instead of the tab closing, the
entire window will close.

Reproducible: Always
Steps to Reproduce:
1. Open a new tab in Mozilla
2. Load a page which continues a "Close this window" link (javascript) (any
page; you can try this fine site:
http://www.microsoft.com/games/midtown/patch_two.htm)
3. Click on the link

Actual Results:  The whole window closes

Expected Results:  The particular tab only should disappear
This bug has been fixed on the trunk and post-1.0 branch builds.

*** This bug has been marked as a duplicate of 103452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.