Make it easier to recognize an extension that have access to the userScript.setScriptAPIs API method

RESOLVED FIXED in Firefox 64

Status

defect
P1
normal
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: rpl, Assigned: rpl)

Tracking

(Blocks 1 bug)

unspecified
mozilla64
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox64 fixed)

Details

Attachments

(3 attachments)

Assignee

Description

7 months ago
This issue goal is to make it easier to recognize an extension that have access to the userScripts.setScriptAPIs API method based on its manifest.json file.
Assignee

Updated

7 months ago
Assignee: nobody → lgreco
Status: NEW → ASSIGNED
Duplicate of this bug: 1498364
Assignee

Updated

7 months ago
Blocks: 1437098
Assignee

Updated

7 months ago
Priority: -- → P1

Comment 5

7 months ago
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/c68fc2d03471
Fix and re-enable userScript test disabled in Bug 1498343. r=zombie
https://hg.mozilla.org/integration/autoland/rev/a0aa0b0aa078
Add more assertions related to behaviors on redefined globals and prototype methods in the userScript tests. r=mixedpuppy
https://hg.mozilla.org/integration/autoland/rev/681ffcabae79
Make it easier to recognize an extension that have access to the userScript.setScriptAPIs API method. r=mixedpuppy

Comment 6

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c68fc2d03471
https://hg.mozilla.org/mozilla-central/rev/a0aa0b0aa078
https://hg.mozilla.org/mozilla-central/rev/681ffcabae79
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Assignee

Comment 7

7 months ago
Marking as qe-verify-, as most of the changes are actually test-only and the only part of it that isn't test-only it is already tested in automated test (as part of the same commit that applied the change).
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.