Closed Bug 1498452 Opened Last year Closed Last year

Blurry icons on Linux

Categories

(Core :: SVG, defect, P3)

62 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 608812

People

(Reporter: karlcow, Unassigned)

References

()

Details

Not sure which Product/Component buckets  this should fall in…

Steps to reproduce
0. with Firefox on Ubuntu
1. Go to  https://github.com/github/linguist/tree/master/vendor
2. Look at the icons



1366x768 screen. The icons next to files/folders look blurry in Firefox, normal (crisp) in Chrome.
https://webcompat.com/uploads/2018/10/a33d1457-eaac-40e6-b47c-a2f2507d9f84.jpg


PS: This doesn't reproduce on Firefox Nightly macOS
Summary: Blurry icons → Blurry icons on Linux
The SVG happens to fall on a pixel boundary here, so its crisp pixel-positioned lines are actually falling between pixels and are blurred across them.

You can hack around this locally by inspecting the icon, clicking up a few levels to its <table> container, and giving it "margin-top: 0.5px" (your mileage may vary -- might need a slightly different value depending on the precise positioning on your system).

Anyway -- this is bug 608812.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 608812
You need to log in before you can comment on or make changes to this bug.