Unable to delete several history items under some circumstances

VERIFIED FIXED in Firefox 64

Status

()

P1
normal
VERIFIED FIXED
4 months ago
4 months ago

People

(Reporter: itiel_yn8, Assigned: mak)

Tracking

({privacy})

unspecified
Firefox 64
privacy
Points:
---

Firefox Tracking Flags

(firefox62 wontfix, firefox63 wontfix, firefox64 verified)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

(Reporter)

Description

4 months ago
Using Windows 10 x86.

STR:
1. Open this URL:
https://bugzilla.mozilla.org/page.cgi?id=user_activity.html&action=run&who=dao%2Bbmo%40mozilla.com
2. Also this URL on a different tab:
https://bugzilla.mozilla.org/page.cgi?id=user_activity.html&action=run&who=dao%2Bbmo%40mozilla.com\
(the only difference being the back slash at the end)
3. Close both tabs, open a new tab
4. Start typing "dao+bmo", you'll see both history entries, one of which is the "Match Failed" one
5. With the down arrow key navigate to it and press the Del key

AR:
The "Match Failed" is removed from the list, but the next time you'll open a new tab and type "dao+bmo", you'll see this entry again.

ER:
The "Match Failed" entry should be removed from history when pressing the Del key.
(Reporter)

Comment 1

4 months ago
Removing other enties in the dropdown using the Del key does actually delete them from history, btw.
(Reporter)

Updated

4 months ago
status-firefox64: --- → affected
(Reporter)

Comment 2

4 months ago
As it turns out, I'm unable to remove the "Match Failed" items from history, never mind where I try to do that (address bar, sidebar, library window).
Component: Address Bar → Untriaged
Summary: Pressing the Del button on a dropdown item doesn't actually remove it from the history, under some circumstances → Unable to delete several history items under some circumstances

Comment 3

4 months ago
Hi Itiel,

Reproduced the issue on the latest Nightly 64.0a1 (2018-10-17), FF Beta 63.0 and FF Release 62.0.3 on Windows 10 x64.
The "Matched failed" entry can't be deleted from history.

Thanks for the report!
status-firefox62: --- → affected
status-firefox63: --- → affected
Component: Untriaged → Bookmarks & History
(Assignee)

Updated

4 months ago
Keywords: privacy
Priority: -- → P1
Whiteboard: [fxsearch]
(Assignee)

Comment 4

4 months ago
Forget About This Site works, Delete page doesn't, and the Address Bar is likely using the same API.
(Assignee)

Updated

4 months ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
(Assignee)

Comment 5

4 months ago
Created attachment 9018244 [details]
Bug 1498584 - Unable to delete urls containing backslashes from history.

Comment 6

4 months ago
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/36e622253bc4
Unable to delete urls containing backslashes from history. r=Standard8

Comment 7

4 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/36e622253bc4
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
status-firefox64: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
(Reporter)

Comment 8

4 months ago
Fixed now on latest Nightly. Thanks!
Status: RESOLVED → VERIFIED
status-firefox64: fixed → verified
status-firefox62: affected → wontfix
status-firefox63: affected → wontfix
You need to log in before you can comment on or make changes to this bug.