All users were logged out of Bugzilla on October 13th, 2018

content between IFRAME - /IFRAME displayed

RESOLVED FIXED in mozilla1.4alpha

Status

()

P2
normal
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: chrilith, Assigned: harishd)

Tracking

Trunk
mozilla1.4alpha
x86
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fix in hand], URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
As given in the W3C spec. for IFRAME :

"The information to be inserted inline is designated by the src attribute of 
this element. The contents of the IFRAME element, on the other hand, should 
only be displayed by user agents that do not support frames or are configured 
not to display frames."

http://www.w3.org/TR/REC-html40/present/frames.html

bug with Mozilla Build ID: 2002053012 and lower (also with NS6)
Check the given URL for example.
(Reporter)

Updated

17 years ago
Target Milestone: --- → mozilla1.0

Comment 1

17 years ago
This is because the IFRAME is never *parsed* as though it has contents, I
believe.  I also believe that fixing it so that it did would break nearly every
site in the world that uses IFRAMEs because they do not close the tag explicitly
and therefore everything after the <IFRAME> would get displayed.

Also, please to not be setting milestone.  Milestone is for the *developer* to
say when he is getting it done.  Just ask in the bug if we can get it done by
Mozilla 1.0 (which is already released, BTW, so we cannot by definition).
Assignee: jkeiser → harishd
Severity: major → normal
Component: HTMLFrames → Parser
QA Contact: amar → moied
Summary: Bug using IFRAME → content between IFRAME - /IFRAME displayed
Target Milestone: mozilla1.0 → ---
we aren't displaying the content here... We _are_ loading the scripts in
question.  We have to.  Consider the (perfectly valid, as far as I can tell)
markup:

  <iframe src="foo">
    Invisible content
  <script>
    document.write("<\/iframe>");
  </script>
  Visible content.
(Assignee)

Comment 3

17 years ago
Created attachment 86878 [details]
Further reduced test case
(Assignee)

Comment 4

17 years ago
Boris: The problem is that the script inside iframe is evaluated! ( refer to my
testcase ). It's a bug.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 5

17 years ago
Boris: Ignore my previous last comment.
(Reporter)

Comment 6

17 years ago
AS i saied you can check this URL :

http://62.210.139.131/oas/test.html

(Assignee)

Comment 7

17 years ago
Created attachment 87116 [details] [diff] [review]
patch v1.0 [ Needs testing ]
(Assignee)

Updated

17 years ago
Priority: -- → P2
Whiteboard: [fix in hand]
Target Milestone: --- → mozilla1.0.1
(Assignee)

Updated

17 years ago
Blocks: 147682
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0.1 → mozilla1.1beta
Target Milestone: mozilla1.1beta → mozilla1.2beta
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.2beta → mozilla1.3alpha
(Assignee)

Comment 8

16 years ago
Created attachment 107957 [details] [diff] [review]
patch v1.1

Handling IFRAME similar to NOFRAMES
Attachment #87116 - Attachment is obsolete: true
(Assignee)

Comment 9

16 years ago
btw, parser regression test PASSED.
(Assignee)

Updated

16 years ago
Attachment #107957 - Flags: superreview?(jst)
Attachment #107957 - Flags: review?(heikki)
Comment on attachment 107957 [details] [diff] [review]
patch v1.1

You should probably add comments to the code where it talks about noframes and
mention iframe there as well, like in CNavDTD.
Attachment #107957 - Flags: review?(heikki) → review+
Comment on attachment 107957 [details] [diff] [review]
patch v1.1

sr=jst
Attachment #107957 - Flags: superreview?(jst) → superreview+
(Assignee)

Comment 12

16 years ago
Fix landed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Blocks: 184029

Comment 13

16 years ago
checkin for this bug caused bug 184029, which is a hang that could potentially
hit many of the sites that use generated/nested iframes (for ad banners, mainly :()
(Assignee)

Comment 14

16 years ago
Andrew: I'm planning on backing out this patch. 
(Assignee)

Comment 15

16 years ago
Backed out the patch to address the issue raised in bug 184029. Reopening the
bug to reinvestigate.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla1.3alpha → mozilla1.3beta
(Assignee)

Updated

16 years ago
Status: REOPENED → ASSIGNED
Target Milestone: mozilla1.3beta → mozilla1.4alpha
This was fixed (probably by the checkin to bug 88952) marking as such.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.