Closed Bug 149913 Opened 18 years ago Closed 15 years ago

Setting display=none and then display = inline on a 100% wide table makes it forget the width.

Categories

(Core :: Layout: Tables, defect, P4)

defect

Tracking

()

RESOLVED DUPLICATE of bug 50626

People

(Reporter: matiasnu, Assigned: karnaze)

Details

Attachments

(1 file)

I tried this on Mac OS X (Mozilla 1.0 Final + NS 7.0PR1) and W2000 (NS 
7.0PR1) and get the same results (it's probably affecting other flavors too;

Setting display=none on a 100% wide table and then display=inline will 
make the table forget that it was 100% wide. Quite annoying indeed if yor 
application depends on it.
Changing the display property of a table to anything other than 'table' 
or 'none' is likely to do odd things. User agents may or may not draw an HTML 
TABLE as a table if you change this property. Toggling the display property 
between 'none' and 'table' works fine.

See: http://www.w3.org/TR/REC-CSS2/tables.html#q2 and the discussion on the 
similar bug 114867 .
OK, I hadn't heard of display=table, better brush up on my CSS2 skills 
then... :) Thanks!

There is also a political perspective to this, since many sites (developed 
for IE)  use display=none and display=block/inline to switch tables on and 
off, but I'll leave that decision to somebody else.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4
"width" does not apply to things with display:inline per CSS, so I'm afraid this
bug is invalid.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → INVALID
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 50626 ***
Status: REOPENED → RESOLVED
Closed: 17 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.