Closed Bug 1499152 Opened Last year Closed Last year

Crash in mozilla::PaintedLayerDataNode::PopAllPaintedLayerData

Categories

(Core :: Web Painting, defect, critical)

x86
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1493438
Tracking Status
firefox63 --- unaffected
firefox64 --- fix-optional

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-e19f2848-adfe-4ff3-9a9b-49a550181009.
=============================================================

Seen while looking at nightly crash data. Crashes started on Windows using 20181008100121: https://bit.ly/2Eo2PIN. So far fairly low volume with 4 Windows crashes.

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=90853a59691e0c77014c38049bfb38b2b6ca1e16&tochange=df860e79a6a3cc41712cfd86ffbd18cf84fce626

Bug 1475139 landed in that timeframe, not sure if it is related or not. ni on rhunt.

Top 10 frames of crashing thread:

0 xul.dll mozilla::PaintedLayerDataNode::PopAllPaintedLayerData layout/painting/FrameLayerBuilder.cpp
1 xul.dll mozilla::FrameLayerBuilder::BuildContainerLayerFor layout/painting/FrameLayerBuilder.cpp:6714
2 xul.dll nsDisplayList::PaintRoot layout/painting/nsDisplayList.cpp:2807
3 xul.dll nsLayoutUtils::PaintFrame layout/base/nsLayoutUtils.cpp:3833
4 xul.dll mozilla::PresShell::Paint layout/base/PresShell.cpp:6350
5 xul.dll nsViewManager::ProcessPendingUpdatesForView view/nsViewManager.cpp:412
6 xul.dll nsRefreshDriver::Tick layout/base/nsRefreshDriver.cpp:2046
7 xul.dll mozilla::RefreshDriverTimer::TickRefreshDrivers layout/base/nsRefreshDriver.cpp:300
8 xul.dll mozilla::RefreshDriverTimer::Tick layout/base/nsRefreshDriver.cpp:318
9 xul.dll mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::TickRefreshDriver layout/base/nsRefreshDriver.cpp:672

=============================================================
Flags: needinfo?(rhunt)
I'm not sure those commits are to blame here. None of them really touched FrameLayerBuilder, and the bulk of the code shouldn't be used at all currently.

I'm going to forward this to Matt Woodrow to see if there's an obvious cause to these crashes.
Flags: needinfo?(rhunt) → needinfo?(matt.woodrow)
Duping to Bug 1493438.
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(matt.woodrow)
Resolution: --- → DUPLICATE
Duplicate of bug: 1493438
You need to log in before you can comment on or make changes to this bug.