Closed Bug 1499369 Opened Last year Closed Last year

Perma browser_dbg_navigation when Gecko 64 merges to Beta on 2018-10-15

Categories

(DevTools :: Framework, defect)

defect
Not set

Tracking

(firefox-esr60 unaffected, firefox62 unaffected, firefox63 unaffected, firefox64+ verified, firefox65 fixed)

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 + verified
firefox65 --- fixed

People

(Reporter: CosminS, Assigned: jdescottes)

Details

Attachments

(1 file)

It is not clear how to reproduce such failure?
And so it is hard to know if I'll correctly fix the error.

Is there a particular merge to do between m-c branches, or it is more related to the changes that are bundled in this try run?
Flags: needinfo?(poirot.alex) → needinfo?(csabou)
This bug also permafails on beta and needs to be fixed.
Flags: needinfo?(spenades)
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
This one seems to fail because of https://searchfox.org/mozilla-central/source/devtools/client/shared/test/browser_dbg_navigation.js#50 which we forgot to remove in Bug 1485660

The reason it fails on beta only is that we call JSON.stringify(event). `event` is undefined in both beta and central, but on beta event is not referenced at all and this creates a ReferenceError which stops the test. I suppose the global must be slightly different between central and beta.
Flags: needinfo?(spenades)
Flags: needinfo?(poirot.alex)
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8c5a1943d169
Remove unreferenced event variable in browser_dbg_navigation.js (beta 64 permafail);r=pbro
https://hg.mozilla.org/mozilla-central/rev/8c5a1943d169
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
You need to log in before you can comment on or make changes to this bug.