utoronto.ca - malformed page due to standards mode

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English Other
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: Andy, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
Homepage rendered in IE 5.x correctly where Mozilla could not.

Comment 1

16 years ago
page renders much better in quirks mode if you remove the DOCTYPE at the begining.

there are several major errors in the page source. this is not a browser/table
problem.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5
The page triggers standards mode by advertising adherence to a current strict
doctype.  Then it fails to adhere to the doctype and worse yet has unterminated
comments like "<!-- comment -- more stuff -->"

As a result, much of the page is commented out and it is shown wrong.

This is evangelism.
Assignee: karnaze → momoi
Component: HTMLTables → English: Non-US
Product: Browser → Tech Evangelism
QA Contact: amar → jeesun
Version: other → unspecified

Comment 3

16 years ago
*** Bug 168817 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
6 months later, the page is still malformed. It does, however, offer the
following helpful message:

"Note: this site does not work with Netscape 7.01"

This is the first time I've seen DOCTYPE HTML 4.01 Frameset on a non-frames
page. As others have said, the most egregious errors could be corrected by
removing the doctype and eliminating the invalid runs of dashes within comments.

Contact addresses are nicholas.martin.sperry@utoronto.ca and
dyang@rotman.utoronto.ca

Updated

16 years ago
Severity: critical → normal
Priority: P5 → --
Summary: Homepage is not rendered correctly. → utoronto.ca - malformed page due to standards mode

Comment 5

16 years ago
I contacted Nicholas Martin Sperry informally and he removed the faulty doctype.

The page looks quite nice now.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 6

15 years ago
Mass reassigning English-Other bugs to general default assignees.
Assignee: momoi → english-other
QA Contact: jeesun → english-other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.