Closed Bug 1499615 Opened 11 months ago Closed 11 months ago

side_effect_free: Calling ++this->mSetSinkRequestsCount is only useful for its return value, which is ignored.

Categories

(Core :: Audio/Video: Playback, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: Sylvestre, Assigned: achronop)

References

(Blocks 1 open bug)

Details

(Keywords: coverity, Whiteboard: [CID 1440248])

Attachments

(1 file)

Flags: needinfo?(achronop)
After doing all the setup and generating the report, I found out that this is the coverage tool something else from coverity tool. Coverity is a static analysis tool. There's no way to test a coverity fix right now. I have to land it and wait for the next coverity build to confirm.

Andreas, given that, are you ok to land this patch as is?
Flags: needinfo?(achronop)
yeah, it will work!
Assignee: nobody → achronop
Pushed by achronopoulos@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cf707f5b0477
Silence unused returned value warning and initialize the counter. r=pehrsons
Priority: -- → P2
https://hg.mozilla.org/mozilla-central/rev/cf707f5b0477
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
I confirmed that the issue is marked as fixed by coverity. Thanks!
Status: RESOLVED → VERIFIED
Thanks for looking at it Sylvestre!
You need to log in before you can comment on or make changes to this bug.