Clicking on inline stylesheet links in then rule-view does not open the right stylesheet in the style-editor

RESOLVED FIXED in Firefox 64

Status

defect
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: pbro, Assigned: pbro)

Tracking

unspecified
Firefox 64

Firefox Tracking Flags

(firefox64 fixed)

Details

(Whiteboard: [dt-q])

Attachments

(1 attachment)

Assignee

Description

7 months ago
STR:
- open http://m8y.org/tmp/testcase466.xhtml
- right-click on one of the paragraphs and select "inspect element"
- in the rule-view, next to the CSS rule that applies to the p elements, click on the inline:2 link

--> expected: the style-editor opens up and shows the right style-sheet, with the cursor at the right location

--> actual: the style-editor opens up, but does not show the right style-sheet.
Assignee

Updated

7 months ago
Assignee: nobody → pbrosset
Status: NEW → ASSIGNED
Assignee

Comment 1

7 months ago
The code we had to jump to the style-editor when a rule-view source link is clicked did
not make any distinction between multiple inline stylesheets. If you had many of them,
they would all have the same url (i.e. the url of the document, because they are
inline). And we were matching stylesheets in the style-editor by url, so we would
always select the first inline stylesheet.

This change makes use of the fact that the style-editor's selectStyleSheet function
also accept a StyleSheetFront object. When passing this object, there can be no
confusion, because they're all different.

Now, I'm only doing this for inlin stylesheets because other stylesheets have unique
urls and it's important to preserve the previous logic since source-maps may also be
involved.

I'm taking this opportunity to re-enable browser_rules_style-editor-link.js which had
been disabled a long time ago, and removing a part that just doesn't work anymore at
all apparently.
Assignee

Updated

7 months ago
Duplicate of this bug: 1481731
Assignee

Updated

7 months ago
Whiteboard: [dt-q]

Comment 3

7 months ago
Pushed by pbrosset@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3a70a65a75cf
Select the right inline stylesheet on rule-view source url click; r=gl

Comment 4

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/3a70a65a75cf
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.