Closed Bug 1500194 Opened 4 years ago Closed 2 years ago

Use IC counters to highlight underperforming IC chains

Categories

(Core :: JavaScript Engine: JIT, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1640284
Tracking Status
firefox64 --- affected

People

(Reporter: mgaudet, Unassigned)

References

Details

In Bug 1494473 counters on the IC chain are being added. 

We should have a spew mode that highlights cases where the IC chain appears to be underperforming.

This will be chains where the entry count at the fallback is approximately the entry count of each element on the chain. For example: 

   1005 -> 1004 -> 1003 -> 1002 -> 1001 -> (fb) 1000

Would be a chain where every IC has failed every time, leading to the creation of five stubs that never provide any value.
Whoops. This is why you don't whip up examples willy nilly. Got the chain backwards: 

    1000 -> 1001 -> 1002 -> 1003 -> 1004 -> (fb) 1005
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1640284
You need to log in before you can comment on or make changes to this bug.