Closed Bug 1500234 Opened 3 years ago Closed 3 years ago

Crash at HTMLMediaElement::ChangeReadyState

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1493766

People

(Reporter: chunmin, Unassigned)

References

Details

Attachments

(1 file)

Attached file crash.html
There is a crash on this line:

https://searchfox.org/mozilla-central/rev/c56977420df7a1b692ce0f7e499ddb364d9fd7b2/dom/html/HTMLMediaElement.cpp#6231

when I allow autoplay on the test page I attach.

Assertion failure: AutoplayPolicy::IsAllowedToPlay(*this), at /Users/cchang/Work/gecko/dom/html/HTMLMediaElement.cpp:6231
#01: mozilla::dom::HTMLMediaElement::UpdateReadyStateInternal()[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x297c8d8]
#02: mozilla::MediaDecoder::OnNextFrameStatus(mozilla::MediaDecoderOwner::NextFrameStatus)[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x2aa54a3]
#03: mozilla::detail::RunnableMethodImpl<mozilla::detail::Listener<mozilla::MediaDecoderOwner::NextFrameStatus>*, void (mozilla::detail::Listener<mozilla::MediaDecoderOwner::NextFrameStatus>::*)(mozilla::MediaDecoderOwner::NextFrameStatus&&), true, (mozilla::R[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x2ae376e]
#04: mozilla::AutoTaskDispatcher::TaskGroupRunnable::Run()[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x10b5ab]
#05: mozilla::EventTargetWrapper::Runner::Run()[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x10a279]
#06: mozilla::SchedulerGroup::Runnable::Run()[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x10747a]
#07: nsThread::ProcessNextEvent(bool, bool*)[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x11ed1e]
#08: NS_ProcessNextEvent(nsIThread*, bool)[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x122a67]
#09: mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*)[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x7639fe]
#10: MessageLoop::Run()[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x715ec7]
#11: nsBaseAppShell::Run()[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x34caa29]
#12: nsAppShell::Run()[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x353a2a8]
#13: XRE_RunAppShell()[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x4c4ae63]
#14: mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*)[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x764242]
#15: MessageLoop::Run()[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x715ec7]
#16: XRE_InitChildProcess(int, char**, XREChildData const*)[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x4c4a98f]
#17: main[/Users/cchang/Work/gecko/obj-x86_64-apple-darwin17.7.0/dist/NightlyDebug.app/Contents/MacOS/plugin-container.app/Contents/MacOS/plugin-container +0xf39]
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1493766
You need to log in before you can comment on or make changes to this bug.