option-minimize displays hidden window in dock

VERIFIED DUPLICATE of bug 223545

Status

defect
--
major
VERIFIED DUPLICATE of bug 223545
17 years ago
11 years ago

People

(Reporter: riscky, Assigned: bugzilla)

Tracking

Trunk
PowerPC
macOS
Bug Flags:
blocking1.3b -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla: 2002060708
Mac OS X: 10.1.5

Open a window then option-minimize brings all Mozilla windows to the dock. With
Jaguar it has been reported users can close windows from the dock... this could
cause problems with jaguar and mozilla.

Comment 1

17 years ago
Confirmed using FizzillaCFM/2002052918 (rv1.0.0). The Hidden Window is shown in the Dock 
following an Option-Minimize operation.

Guessing XP Apps: GUI Features and raising Severity.
Assignee: Matti → blaker
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps: GUI Features
Ever confirmed: true
QA Contact: imajes-qa → paw
Hmmm... doing some reading this looks like the OS is doing the work here. 
Option-click even does utility windows which 'you can't minimize' (in other
applications). Even with custom windows

http://developer.apple.com/techpubs/macosx/Carbon/HumanInterfaceToolbox/WindowManager/HandlingWindowsControls/hitb-wind_cont_tasks/Custom_Wind_nd_Controls.html

I'm not seeing a minimize event which could be ignored. 

I suppose some kind of idle-time task could always be unminimizing the Hidden
window, to hack around it, but ick.  I don't know enough Mozilla guts to propose
anything serious.

Comment 3

17 years ago
this also happens when cycling windows (command-` aka command-~), causing
something of a ui issue - no visible window has focus.
Flags: blocking1.3b?

Updated

17 years ago
Flags: blocking1.3b? → blocking1.3b-

Comment 4

16 years ago
*** Bug 206895 has been marked as a duplicate of this bug. ***
Duping to bug 223545, since it has a patch to fix this.

*** This bug has been marked as a duplicate of 223545 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

11 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.