Closed Bug 1500415 Opened 3 years ago Closed 2 years ago

[Wayland][WebRender] font/images/textures broken

Categories

(Core :: Graphics: WebRender, defect, P3)

64 Branch
Unspecified
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox64 --- disabled
firefox65 --- disabled

People

(Reporter: rmader, Assigned: stransky)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0

Steps to reproduce:

Start the flatpak nightly in a gnome wayland session

fedora 29, gnome 3.30.1, thinkpad x230 (ivybridge)


Actual results:

Fonts and images in the main window/surface are broken. In menus (subsurfaces?) it works fine.


Expected results:

Fonts and images should get displayed correctly everywhere
Blocks: wayland
OS: Unspecified → Linux
Version: 63 Branch → 64 Branch
Component: General → Graphics
I bet that's more flatpak than Wayland issue - I'll test that.
Assignee: nobody → stransky
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Just wanted to add that I was able to reproduce this on a Thinkpad T440s, fedora 29
I can reproduce outside of flatpak, on archlinux, dell xps 13. Le
Reproduced here too (FreeBSD/Weston/Radeon).

This definitely broke recently, used to work fine.
Priority: -- → P3
I managed to work around/fix this by fixing bug 1474281
So it's likely a webrender bug when running on GLES
Also filled a bug for webrender: https://github.com/servo/webrender/issues/3319
So is that WebRender only issue or can you reproduce it with acceleration disabled?
Flags: needinfo?(robert.mader)
This only happens when using WebRender.
As pointed out before, it does not happen when using desktop GL. I therefore suspect it to be a WebRender/GLES issue, but don't really now. I haven't tested it in the last two weeks, though, and will give you a fresh feedback tomorrow.
Flags: needinfo?(robert.mader)
Blocks: wr-linux
Component: Graphics → Graphics: WebRender
Just compiled latest tip and while accelerated layers work fine, webrender only shows window decorations while the area in between stays transparent (no surface commited I guess). This also doesn't change with the patch from bug 1474281 (which also works fine for accelerated layers)

So currently webrender just fails for me (18.2.6, intel skylake)
(In reply to robert.mader from comment #9)
> Just compiled latest tip and while accelerated layers work fine, webrender
> only shows window decorations while the area in between stays transparent
> (no surface commited I guess). This also doesn't change with the patch from
> bug 1474281 (which also works fine for accelerated layers)
> 
> So currently webrender just fails for me (18.2.6, intel skylake)

Yes I see the same - I wonder what causes it. Plain OpenGL works with patch from Bug 1512589.
Duplicate of this bug: 1485616
Not sure if it's related but I see on terminal:

Crash Annotation GraphicsCriticalError: |[0][GFX1-]: shader-cache: Shader disk cache is not supported (t=2.37896) [GFX1-]: shader-cache: Shader disk cache is not supported
ERROR 2018-12-10T14:50:04Z: webrender_bindings::program_cache: shader-cache: Shader disk cache is not supported

and compositor switches from WebRender to OpenGL.
That's bug 1511726.
Apart from bug 1514156, which currently breaks wayland+wr for in most cases, in the cases where ff does manage to start up, things are renderer fine again. Greg, can you confirm that?

The bug as reported is now fixed, so closing.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.