Closed Bug 1500475 Opened Last year Closed Last year

Intermittent devtools/client/webconsole/test/mochitest/browser_jsterm_content_defined_helpers.js | output is correct for $0() -

Categories

(DevTools :: Console, defect, P5)

defect

Tracking

(firefox64 fixed, firefox65 fixed)

RESOLVED FIXED
Firefox 65
Tracking Status
firefox64 --- fixed
firefox65 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: nchevobbe)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

Filed by: cbrindusan [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=206604067&repo=autoland

https://queue.taskcluster.net/v1/task/Pma6G-59TiWgiwklxU0LBQ/runs/0/artifacts/public/logs/live_backing.log

13:20:15     INFO - TEST-START | devtools/client/webconsole/test/mochitest/browser_jsterm_content_defined_helpers.js
13:20:15     INFO - GECKO(4720) | ++DOCSHELL 085F2800 == 3 [pid = 3548] [id = {950b2e85-d6d7-44a9-9b97-18191a4cf91f}]
13:20:15     INFO - GECKO(4720) | [Child 3548, Main Thread] WARNING: NS_ENSURE_TRUE(browserChrome) failed: file z:/build/build/src/docshell/base/nsDocShell.cpp, line 12726
13:20:15     INFO - GECKO(4720) | ++DOMWINDOW == 7 (0851D540) [pid = 3548] [serial = 125] [outer = 00000000]
13:20:15     INFO - GECKO(4720) | ++DOMWINDOW == 8 (097A4400) [pid = 3548] [serial = 126] [outer = 0851D540]
13:20:15     INFO - GECKO(4720) | ++DOMWINDOW == 9 (097A7400) [pid = 3548] [serial = 127] [outer = 0851D540]
13:20:15     INFO - GECKO(4720) | ++DOCSHELL 19E8C400 == 9 [pid = 1400] [id = {376c09b6-4c80-439c-a761-0fa902ba42fb}]
13:20:15     INFO - GECKO(4720) | [Parent 1400, Main Thread] WARNING: NS_ENSURE_TRUE(browserChrome) failed: file z:/build/build/src/docshell/base/nsDocShell.cpp, line 12726
13:20:15     INFO - GECKO(4720) | [Parent 1400, Main Thread] WARNING: NS_ENSURE_TRUE(browserChrome) failed: file z:/build/build/src/docshell/base/nsDocShell.cpp, line 12726
13:20:15     INFO - GECKO(4720) | [Parent 1400, Main Thread] WARNING: NS_ENSURE_TRUE(browserChrome) failed: file z:/build/build/src/docshell/base/nsDocShell.cpp, line 12726
13:20:15     INFO - GECKO(4720) | ++DOMWINDOW == 31 (0B25A540) [pid = 1400] [serial = 485] [outer = 00000000]
13:20:15     INFO - GECKO(4720) | ++DOMWINDOW == 32 (19E93C00) [pid = 1400] [serial = 486] [outer = 0B25A540]
13:20:15     INFO - GECKO(4720) | ++DOMWINDOW == 33 (1A5A6800) [pid = 1400] [serial = 487] [outer = 0B25A540]
13:20:15     INFO - GECKO(4720) | ++DOCSHELL 19E91400 == 10 [pid = 1400] [id = {a4f2e2e1-876f-45eb-b254-0452069bd347}]
13:20:15     INFO - GECKO(4720) | [Parent 1400, Main Thread] WARNING: NS_ENSURE_TRUE(browserChrome) failed: file z:/build/build/src/docshell/base/nsDocShell.cpp, line 12726
13:20:15     INFO - GECKO(4720) | [Parent 1400, Main Thread] WARNING: NS_ENSURE_TRUE(browserChrome) failed: file z:/build/build/src/docshell/base/nsDocShell.cpp, line 12726
13:20:15     INFO - GECKO(4720) | [Parent 1400, Main Thread] WARNING: NS_ENSURE_TRUE(browserChrome) failed: file z:/build/build/src/docshell/base/nsDocShell.cpp, line 12726
13:20:15     INFO - GECKO(4720) | ++DOMWINDOW == 34 (20281D00) [pid = 1400] [serial = 488] [outer = 00000000]
13:20:15     INFO - GECKO(4720) | ++DOMWINDOW == 35 (19E96800) [pid = 1400] [serial = 489] [outer = 20281D00]
13:20:16     INFO - GECKO(4720) | --DOCSHELL 085E7C00 == 2 [pid = 3548] [id = {aedd9ae8-b4ef-4b23-b71d-a4ba9817ebe1}]
13:20:16     INFO - GECKO(4720) | [Parent 1400, Main Thread] WARNING: '!NodeIsInTraversalRange(mLast, mPre, RawRangeBoundary(mFirst, 0), aEnd)', file z:/build/build/src/dom/base/nsContentIterator.cpp, line 433
13:20:16     INFO - GECKO(4720) | [Parent 1400, Main Thread] WARNING: '!NodeIsInTraversalRange(mLast, mPre, RawRangeBoundary(mFirst, 0), aEnd)', file z:/build/build/src/dom/base/nsContentIterator.cpp, line 433
13:20:17     INFO - GECKO(4720) | [Parent 1400, Main Thread] WARNING: '!NodeIsInTraversalRange(mLast, mPre, RawRangeBoundary(mFirst, 0), aEnd)', file z:/build/build/src/dom/base/nsContentIterator.cpp, line 433
13:20:17     INFO - GECKO(4720) | [Parent 1400, Main Thread] WARNING: '!NodeIsInTraversalRange(mLast, mPre, RawRangeBoundary(mFirst, 0), aEnd)', file z:/build/build/src/dom/base/nsContentIterator.cpp, line 433
13:20:17     INFO - TEST-INFO | started process screenshot
13:20:17     INFO - TEST-INFO | screenshot: exit 0
13:20:17     INFO - Buffered messages logged at 13:20:15
13:20:17     INFO - Entering test bound 
13:20:17     INFO - Adding a new tab with URL: data:text/html,<meta charset=utf8>
13:20:17     INFO -   <script>
13:20:17     INFO -     const helpers = ["$_","$","$$","$0","$x","cd","clear","clearHistory","copy","help","inspect","keys","pprint","screenshot","values"];
13:20:17     INFO -     for (const helper of helpers) {
13:20:17     INFO -       window[helper] = () => "content-" + helper;
13:20:17     INFO -     }
13:20:17     INFO -   </script>
13:20:17     INFO - Tab added and finished loading
13:20:17     INFO - Opening the toolbox
13:20:17     INFO - Buffered messages logged at 13:20:16
13:20:17     INFO - Toolbox opened and focused
13:20:17     INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_jsterm_content_defined_helpers.js | There's no duplicated "$_" item in the autocomplete popup - 
13:20:17     INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_jsterm_content_defined_helpers.js | output is correct for $_() - 
13:20:17     INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_jsterm_content_defined_helpers.js | There's no duplicated "$" item in the autocomplete popup - 
13:20:17     INFO - Buffered messages logged at 13:20:17
13:20:17     INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_jsterm_content_defined_helpers.js | output is correct for $() - 
13:20:17     INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_jsterm_content_defined_helpers.js | There's no duplicated "$$" item in the autocomplete popup - 
13:20:17     INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_jsterm_content_defined_helpers.js | output is correct for $$() - 
13:20:17     INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_jsterm_content_defined_helpers.js | There's no duplicated "$0" item in the autocomplete popup - 
13:20:17     INFO - Buffered messages finished
13:20:17     INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/mochitest/browser_jsterm_content_defined_helpers.js | output is correct for $0() - 
13:20:17     INFO - Stack trace:
13:20:17     INFO - chrome://mochitests/content/browser/devtools/client/webconsole/test/mochitest/browser_jsterm_content_defined_helpers.js:performTests:58
13:20:17     INFO - chrome://mochitests/content/browser/devtools/client/webconsole/test/mochitest/browser_jsterm_content_defined_helpers.js:null:42
13:20:17     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1093
13:20:17     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1084
13:20:17     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:986
13:20:17     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
The log we currently receive are not really
actionable (we are using ok, so we don't know
what the received value actually is). Switching
to is should give us what the value is when the
test fails, which might help us fix the failure.
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a159b99e2a0b
Modify browser_jsterm_content_defined_helpers.js to find cause of intermittent; r=bgrins.
leave-open as the patch that I just pushed won't resolve the intermittent but will give you more detail to fix it.
Keywords: leave-open
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9a6f5e359f1d
Fix browser_jsterm_content_defined_helpers.js intermittent; r=Honza.
Shall this bug lose its leave-open and be resolved as fixed? Shall the other recent failures of this test be set as duplicates?
Flags: needinfo?(nchevobbe)
(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #9)
> Shall this bug lose its leave-open and be resolved as fixed? 

Yes, sorry I forgot to remove it when pushing the fix.

> Shall the other recent failures of this test be set as duplicates?

yes, I think they all had the same root cause.
Flags: needinfo?(nchevobbe)
Keywords: leave-open
Assignee: nobody → nchevobbe
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
This was frequent on central. In case it's not preffed off in beta, please request uplift to beta. Version increase to 65 was yesterday and the commit missed to get into 64.
Flags: needinfo?(nchevobbe)
Target Milestone: --- → Firefox 65
Comment on attachment 9018954 [details]
Bug 1500475 - Fix browser_jsterm_content_defined_helpers.js intermittent; r?Honza.

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: none, but failures will still happen on 64 branch

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: https://bugzilla.mozilla.org/attachment.cgi?id=9018648

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Intermittent fix, only the test was modified

String changes made/needed:
Flags: needinfo?(nchevobbe)
Attachment #9018954 - Flags: approval-mozilla-beta?
Comment on attachment 9018954 [details]
Bug 1500475 - Fix browser_jsterm_content_defined_helpers.js intermittent; r?Honza.

test-only changes don't need approval
Attachment #9018954 - Flags: approval-mozilla-beta?
You need to log in before you can comment on or make changes to this bug.